Opened 13 years ago

Closed 13 years ago

Last modified 13 years ago

#1670 closed defect (invalid)

Error: ReferenceError: [methodName] is not defined

Reported by: José Renato (jose@… Owned by: mumme
Priority: high Milestone:
Component: Widgets Version: 0.3
Keywords: ReferenceError Cc:
Blocked By: Blocking:

Description

A content pane that recieves its content on the fly does not find inner scripts throwing error:

[Exception... "'Error: ReferenceError?: [methodName] is not defined' when calling method: [nsIDOMEventListener::handleEvent]" nsresult: "0x8057001c (NS_ERROR_XPC_JS_THREW_JS_OBJECT)" location: "<unknown>" data: no]

It follows test page as attachment

Attachments (1)

swapMethod.rar (2.2 KB) - added by José Renato (jose@… 13 years ago.
It contains test pages to reproduce the error

Download all attachments as: .zip

Change History (4)

Changed 13 years ago by José Renato (jose@…

Attachment: swapMethod.rar added

It contains test pages to reproduce the error

comment:1 Changed 13 years ago by mumme

Owner: changed from bill to mumme

comment:2 Changed 13 years ago by mumme

Resolution: invalid
Status: newclosed

Thank you José for this extensive testcase.

However It does work as intended, agreed it might be tricky understand how scripts work when they are set from a remote resource.

First you need to turn on scripts by setting executeScripts="true" in your main ContentPane?, second you need to point your eventhandler to your main ContentPane? scriptScope, by changing

onHide="damnitTwo(false)"
to
onHide="scriptScope.damnitTwo(false)"

In 0.4 you can also make all remotescript eval in global scope by setting scriptSeparation="false"

When I change your contentpane declaration tag to

<div dojoType="ContentPane" id="main" style="width: 320px; height: 480px;" executeScripts='true' scriptSeparation="false">

and leave the rest it works with 0.4

The flicker/hiding you experience from content below the accordion pane has to do with the style="overflow: scroll;"

I think you should open a separete bug on this one, it is much easier to track that way.

/ Fredrik

comment:3 Changed 13 years ago by (none)

Milestone: 0.4.1

Milestone 0.4.1 deleted

Note: See TracTickets for help on using tickets.