Opened 7 years ago

Closed 7 years ago

#16697 closed defect (invalid)

focus problem on ipad when using ckeditor and "screen magnifier" function

Reported by: Leath Owned by: Leath
Priority: undecided Milestone: tbd
Component: Events Version: 1.8.3
Keywords: Cc: christoph@…
Blocked By: Blocking:

Description

  • Browser Type: All
  • Device: Ipad / Iphone
  • OS: iOS 6.0.1

Description:

When using the ckEditor in connection with dojo, the "screen magnifier"-function does not work correctly. When touching the screen for a second, the IPad switches into the magnifier-mode to easily position the cursor at the right place. The problem is, that the editor is getting stucked when the touch event is release, not able to write characters any more. The only way to get the editor working again is to focus another html input node or something out of the editors scope.

By tracking down the error, it turned out, that something goes wrong with dojo, touch events and how they are handled.

The problem occures, f.e. when using the dijit/Tooltip module.


Contact: Christoph Schönfeld christoph@…

Change History (2)

comment:1 Changed 7 years ago by bill

Cc: christoph@… added
Owner: changed from Kris Zyp to Leath
Status: newpending

What does ckEditor have to do with dojo?

PS: you should register your email in trac rather than adding it to tickets.

PPS: If you are saying that you have a page with dojo and ckEditor on it, then please (a) attach a test case with instructions on how to reproduce and (b) explain why and where you think the problem in the touch code is. Thanks.

Last edited 7 years ago by bill (previous) (diff)

comment:2 Changed 7 years ago by trac-o-bot

Resolution: invalid
Status: pendingclosed

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

Note: See TracTickets for help on using tickets.