Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#16683 closed feature (fixed)

dijit/selection

Reported by: bill Owned by: bill
Priority: undecided Milestone: 1.9
Component: Dijit Version: 1.9.0b2
Keywords: Cc: cjolif
Blocked By: Blocking:

Description

Make a dijit/selection module based on dijit/_editor/selection but don't depend on deprecated win.withGlobal() etc. to use it on a window other than the main window. That's because win.withGlobal() likely won't be supported in the next major release of dojo.

On a related note, Editor shouldn't depend on dijit/_base/focus either.

Change History (13)

comment:1 Changed 6 years ago by bill

Milestone: tbd1.9
Status: newassigned

comment:2 Changed 6 years ago by bill

Resolution: fixed
Status: assignedclosed

In [30561]:

New dijit/selection module to replace dijit/_editor/selection. Dijit/selection is a singleton, but the class is also available selection.SelectionManager?, so new selection.SelectionManager?(myWindow) creates a new instance to run against any window. Fixes #16683 !strict.

comment:3 Changed 6 years ago by bill

In [31232]:

Make dijit/selection.isTag() public (like it was in dojox/_editor/selection) since dojox/editor/pageBreak is depending on it, refs #16683 !strict.

comment:4 Changed 6 years ago by bill

In [31279]:

Move getBookmark() and moveToBookmark() from deprecated dijit/_base/focus to dijit/selection. This eliminates the Editor dependency on deprecated dijit/_base/focus, but the code is still weird in that editor has it's own enhanced version of getBookmark() and moveToBookmark() that tweak the results of the original methods. Refs #16683 !strict.

comment:5 Changed 6 years ago by haysmark

Resolution: fixed
Status: closedreopened
Summary: dijit/selection[regression] dijit/selection
Version: 1.8.31.9.0b2

See:

http://archive.dojotoolkit.org/nightly/checkout/dijit/tests/_base/robot/FocusManager.html

Starting with [31279], the test dijit/tests/_base/FocusManager fails in IE9 and IE10.

  • In IE9, the test fails to delete the word "world". On my local copy, the text appears selected, but on archive, the text is not selected at all.
  • In IE10, the focus is restored incorrectly, resulting in the string "helo world".
Last edited 6 years ago by haysmark (previous) (diff)

comment:6 Changed 6 years ago by haysmark

Also worth noting that we need a 1.9RC version # as this occurs in the 1.9 RC, not b2.

comment:7 Changed 6 years ago by haysmark

Keywords: dohfail added

comment:8 Changed 6 years ago by cjolif

Cc: cjolif added

comment:9 Changed 6 years ago by bill

OK, I actually left out a dependency from selection.js. I'll add that in.

comment:10 Changed 6 years ago by bill

Resolution: fixed
Status: reopenedclosed

In [31325]:

Fix missing dependency in selection.js, and replace test file references to dijit/_base/focus code, since it isn't pulled in anymore. Fixes #16683 !strict.

comment:11 Changed 6 years ago by bill

Keywords: dohfail removed
Summary: [regression] dijit/selectiondijit/selection

comment:12 Changed 6 years ago by bill

In [31399]:

For EnterKeyHandling, use dijit/selection rather than deprecated dijit/_base/focus, refs #16683 !strict.

comment:13 Changed 6 years ago by bill

In [31418]:

lint fix (use comma not semicolon), refs #16683 !strict

Note: See TracTickets for help on using tickets.