Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#16677 closed defect (worksforme)

build error: use base.profile.js build dojo 1.9.0dev failure

Reported by: jzw Owned by: jzw
Priority: undecided Milestone: tbd
Component: BuildSystem Version: 1.8.3
Keywords: Cc:
Blocked By: Blocking:

Description

In latest dojo version, 1.9.0dev,I build dojo use "profiles/base.profile.js" throw below error:

error(354) Root bundle indicates localized bundles that don't exist. 
Root: dojo/cldr/nls/persian; missing bundles: 
'bs-cyrl','fa','fa-af','hi','id','lo','ps','sr','uk','vi'.

Change History (16)

comment:1 Changed 7 years ago by Colin Snover

Owner: changed from Rawld Gill to Adam Peller
Status: newassigned

comment:2 Changed 7 years ago by Adam Peller

Are you running with the latest code? This was fixed 7 days ago: [30486]

comment:3 Changed 7 years ago by Adam Peller

Owner: changed from Adam Peller to jzw
Status: assignedpending

comment:4 Changed 7 years ago by jzw

Status: pendingnew

yes, is latest code, and i check the code in https://github.com/dojo/dojo/blob/master/cldr/nls/persian.js

on Jan 28, 2013,you adding persian CLDR resources Refs #16581, but on Jan 29, 2013, Remove missing references in [30479] Refs #16581

so the latest persian.js missing bundles

the latest code is

	"ar": true,
	"hu": true,
	"ja": true,
	"pl": true,
	"pt": true,
	"ru": true,
	"sv": true,
	"th": true,
	"tr": true,
	"zh": true,
	"zh-hant": true

missing

'bs-cyrl','fa','fa-af','hi','id','lo','ps','sr','uk','vi'.

comment:5 Changed 7 years ago by jzw

@peller

Did you build the latest code passed?

Last edited 7 years ago by jzw (previous) (diff)

comment:7 Changed 7 years ago by jzw

I made a mistake, it's not the latest code. sorry.

comment:8 Changed 7 years ago by jzw

hi peller

I use java + closure build the latest code, throw error:

js: "<eval'ed string>#1(Function)#1(eval)", line 28: uncaught JavaScript runtime exception: TypeError: Cannot call method "match" of undefined
	at <eval'ed string>#1(Function)#1(eval):28
	at <eval'ed string>#1(Function)#1(eval):84

then I use node + uglifyjs throw errors error(356) The optimizer threw an exception; the module probably contains syntax errors. module identifier: dojo/dojo; exception: Unexpected token: operator (<) (line: 8236, col: 1, pos: 278628)

Error

at new JS_Parse_Error (/home/git/UglifyJS/UglifyJS/lib/parse-js.js:260:22) at js_error (/home/git/UglifyJS/UglifyJS/lib/parse-js.js:268:15) at croak (/home/git/UglifyJS/UglifyJS/lib/parse-js.js:729:17) at token_error (/home/git/UglifyJS/UglifyJS/lib/parse-js.js:736:17) at unexpected (/home/git/UglifyJS/UglifyJS/lib/parse-js.js:742:17) at /home/git/UglifyJS/UglifyJS/lib/parse-js.js:1120:17 at maybe_unary (/home/git/UglifyJS/UglifyJS/lib/parse-js.js:1205:27) at expr_ops (/home/git/UglifyJS/UglifyJS/lib/parse-js.js:1232:32) at maybe_conditional (/home/git/UglifyJS/UglifyJS/lib/parse-js.js:1236:28) at maybe_assign (/home/git/UglifyJS/UglifyJS/lib/parse-js.js:1260:28) at /home/git/UglifyJS/UglifyJS/lib/parse-js.js:1274:28 at prog1 (/home/git/UglifyJS/UglifyJS/lib/parse-js.js:1308:23)

then I find at the bottom of dojo.js.uncompressed.js contains code

<!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN">
<html><head>
<title>404 Not Found</title>
</head><body>
<h1>Not Found</h1>
<p>The requested URL /home/git/private/dojo/static/util/build/transforms/dojoBoot.js was not found on this server.</p>
<hr>
<address>Apache/2.2.22 (Ubuntu) Server at localhost Port 80</address>
</body></html>

but the dojoBoot.js indeed in my /home/git/private/dojo/static/util/build/transforms/ folder

why append this html code in the dojo.js.uncompressed.js?

before I pull the latested code, I build success...

if you build use "adm.profile.js" maybe can reproduce my error.

I find my config error again and again, can not find the reason, help please, thanks!

Last edited 7 years ago by jzw (previous) (diff)

comment:9 in reply to:  2 Changed 7 years ago by jzw

Replying to peller:

Are you running with the latest code? This was fixed 7 days ago: [30486]

Hi peller, Thanks,I made a mistake, it's not the latest code.

But after I pull the latest code, I still can not build success. I use java + closure build the latest code, throw error:

js: "<eval'ed string>#1(Function)#1(eval)", line 28: uncaught JavaScript runtime exception: TypeError: Cannot call method "match" of undefined
	at <eval'ed string>#1(Function)#1(eval):28
	at <eval'ed string>#1(Function)#1(eval):84

then I use node + uglifyjs throw errors error(356) The optimizer threw an exception; the module probably contains syntax errors. module identifier: dojo/dojo; exception: Unexpected token: operator (<) (line: 8236, col: 1, pos: 278628)

Error

at new JS_Parse_Error (/home/git/UglifyJS/UglifyJS/lib/parse-js.js:260:22) at js_error (/home/git/UglifyJS/UglifyJS/lib/parse-js.js:268:15) at croak (/home/git/UglifyJS/UglifyJS/lib/parse-js.js:729:17) at token_error (/home/git/UglifyJS/UglifyJS/lib/parse-js.js:736:17) at unexpected (/home/git/UglifyJS/UglifyJS/lib/parse-js.js:742:17) at /home/git/UglifyJS/UglifyJS/lib/parse-js.js:1120:17 at maybe_unary (/home/git/UglifyJS/UglifyJS/lib/parse-js.js:1205:27) at expr_ops (/home/git/UglifyJS/UglifyJS/lib/parse-js.js:1232:32) at maybe_conditional (/home/git/UglifyJS/UglifyJS/lib/parse-js.js:1236:28) at maybe_assign (/home/git/UglifyJS/UglifyJS/lib/parse-js.js:1260:28) at /home/git/UglifyJS/UglifyJS/lib/parse-js.js:1274:28 at prog1 (/home/git/UglifyJS/UglifyJS/lib/parse-js.js:1308:23)

then I find at the bottom of dojo.js.uncompressed.js contains code

<!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN">
<html><head>
<title>404 Not Found</title>
</head><body>
<h1>Not Found</h1>
<p>The requested URL /home/git/private/dojo/static/util/build/transforms/dojoBoot.js was not found on this server.</p>
<hr>
<address>Apache/2.2.22 (Ubuntu) Server at localhost Port 80</address>
</body></html>

but the dojoBoot.js indeed in my /home/git/private/dojo/static/util/build/transforms/ folder

why append this html code in the dojo.js.uncompressed.js?

before I pull the latested code, I build success...

if you build use "adm.profile.js" maybe can reproduce my error.

I find my config error again and again, can not find the reason, help please, thanks

Last edited 7 years ago by jzw (previous) (diff)

comment:10 Changed 7 years ago by bill

Then you still don't have the latest code, I fixed that problem in [30537].

comment:11 in reply to:  10 Changed 7 years ago by jzw

Replying to bill:

Then you still don't have the latest code, I fixed that problem in [30537].

Hi, bill yes use node + uglifyjs, build system works now.

but java + closure still throw errors

js: "<eval'ed string>#1(Function)#1(eval)", line 28: uncaught JavaScript runtime exception: TypeError: Cannot call method "match" of undefined
	at <eval'ed string>#1(Function)#1(eval):28
	at <eval'ed string>#1(Function)#1(eval):84

thanks, I use node + uglifyjs to build, it not block my work now :)

comment:12 Changed 7 years ago by Colin Snover

Resolution: worksforme
Status: newclosed

comment:13 Changed 7 years ago by bill

@jzw - What was the exact command that was failing with closure compiler? Closure compiler should work too, but this is working for me:

$ ./build.sh --release --releaseDir /ws/release --optimize closure --profile base

comment:14 Changed 7 years ago by bill

In [30555]:

rhino fails just loading the dojo/request module, so need to has() bracket it, fixes regression from [30524], refs #16664, #16677 !strict.

comment:15 in reply to:  13 Changed 7 years ago by jzw

Replying to bill:

@jzw - What was the exact command that was failing with closure compiler? Closure compiler should work too, but this is working for me:

$ ./build.sh --release --releaseDir /ws/release --optimize closure --profile base

Thanks bill care more this ticket after it closed.

In build.sh help, I did not find optimize switch, I use this:

./build.sh --bin java --profile base --action release

Is this script right, did I make something wrong?

Last edited 7 years ago by jzw (previous) (diff)

comment:16 Changed 7 years ago by bill

OK thanks. It's fine to get the optimization setting from the profile rather than putting it on the command line. As for --bin java I wouldn't use it, because node runs much faster. In other words, IIUC this is recommended:

./build.sh --profile base --action release

It will use node rather than rhino to run the general build, but then call java to run closure.

Note: See TracTickets for help on using tickets.