Opened 6 years ago

Closed 6 years ago

#16651 closed defect (fixed)

dojox.mobile._StoreMixin is registering too many observer handlers

Reported by: dg Owned by: Eric Durocher
Priority: undecided Milestone: 1.9
Component: DojoX Mobile Version: 1.8.3
Keywords: Cc:
Blocked By: Blocking:

Description

On a store list, setting several times the query via setQuery() will register as many observer handlers. When setting the query, refresh function is called. This function is registering another observer on the store that hasn't changed. Suggested fix: observe() function is returning an object with the remove() function. This function must be called before registering a new observer.

To reproduce with the sample, add a new item, change the sorting function several times, click on delete.

Attachments (1)

test_EdgeToEdgeStoreList-putSort.html (4.3 KB) - added by dg 6 years ago.
Test case for _StoreMixin support for setQUery() operation - IBM, CCLA

Download all attachments as: .zip

Change History (6)

Changed 6 years ago by dg

Test case for _StoreMixin support for setQUery() operation - IBM, CCLA

comment:1 Changed 6 years ago by ben hockey

#16650 is a duplicate of this ticket.

comment:2 Changed 6 years ago by Eric Durocher

A precise reproduction sequence is: click Add, Sort on Value, Sort on Label, Delete => 2 items are deleted ("New Item 1" and "iPod"), whereas only "New Item 1" should be deleted.

comment:3 Changed 6 years ago by Eric Durocher

The patch for #16643 should also fix this defect.

comment:4 Changed 6 years ago by cjolif

Milestone: tbd1.9

comment:5 Changed 6 years ago by cjolif

Resolution: fixed
Status: newclosed

In [30581]:

fixes #16651. refs #16643. Fixes on store management + add support for put operation. Thanks Eric Durocher (IBM, CCLA).

Note: See TracTickets for help on using tickets.