Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#16650 closed defect (duplicate)

dojox.mobile._StoreMixin is registering too many observer handlers

Reported by: dg Owned by:
Priority: undecided Milestone: tbd
Component: General Version: 1.8.3
Keywords: Cc:
Blocked By: Blocking:

Description

On a store list, setting several times the query via setQuery() will register as many observer handlers. When setting the query, refresh function is called. This function is registering another observer on the store that hasn't changed. Suggested fix: observe() function is returning an object with the remove() function. This function must be called before registering a new observer.

To reproduce with the sample, add a new item, change the sorting function several times, click on delete.

Change History (2)

comment:1 Changed 7 years ago by ben hockey

Resolution: duplicate
Status: newclosed

Duplicate of #16651.

comment:2 Changed 7 years ago by dg

Sorry for the inconvenience, my browser was frozen for a too long time when I created it, I thought it failed... :/

Note: See TracTickets for help on using tickets.