Opened 15 years ago

Last modified 10 years ago

#1663 closed defect

fix loader.js comments and function names — at Version 1

Reported by: bill Owned by: James Burke
Priority: low Milestone: 1.7
Component: Loader Version: 0.3
Keywords: needsreview Cc:
Blocked By: Blocking:

Description (last modified by bill)

As per the recent discussion to call dojo.html a module and dojo.html.common a resource... the comments and function/variable names in loader.js need to be updated. Here's a partial list of suggested updates:

  • rename private functions to have _ in front of them
  • rename loaded_modules --> loaded_resources
  • rename startPackage --> startModule, or roll startPackage() code into dojo.provide(); unclear if a separate function is needed. in any case the comment for the function is confusing because it talks about creating javascript objects, which is more of an implementation detail than a guaranteed api. (contrast w/the comment for dojo.provide)
  • rename findModule -> findResource
  • loadPath - the comment should say it loads resources, or at the least, it shouldn't use the word "modules"
  • modulesLoaded - could be resourcesLoaded? should probably have an underscore
  • signature for addOnLoad/addOnUnload is better written as function(/*Object?*/obj, /*String|Function*/functionName). The first argument is optional and the second is mandatory.

Change History (1)

comment:1 Changed 15 years ago by bill

Description: modified (diff)
Note: See TracTickets for help on using tickets.