Changes between Initial Version and Version 1 of Ticket #1663


Ignore:
Timestamp:
Oct 17, 2006, 6:20:20 AM (13 years ago)
Author:
bill
Comment:

Legend:

Unmodified
Added
Removed
Modified
  • Ticket #1663 – Description

    initial v1  
    22
    33 * rename private functions to have _ in front of them
    4  * loaded_modules --> loaded_resources
    5  * startPackage --> startModule?  or roll code into dojo.provide()? unclear if a separate function is neede
    6  * findModule -> findResource
     4 * rename loaded_modules --> loaded_resources
     5 * rename startPackage --> startModule, or roll startPackage() code into dojo.provide(); unclear if a separate function is needed.  in any case the comment for the function is confusing because it talks about creating javascript objects, which is more of an implementation detail than a guaranteed api.  (contrast w/the comment for dojo.provide)
     6 * rename findModule -> findResource
    77 * loadPath - the comment should say it loads resources, or at the least, it shouldn't use the word "modules"
    88 * modulesLoaded - could be resourcesLoaded?  should probably have an underscore
     9 * signature for addOnLoad/addOnUnload is better written as function(/*Object?*/obj, /*String|Function*/functionName).  The first argument is optional and the second is mandatory.
    910