Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#16635 closed defect (fixed)

Dialog: screen reader problems due to unwanted title="" attribute on this.domNode

Reported by: bill Owned by: bill
Priority: undecided Milestone: 1.7.5
Component: Dijit Version: 1.8.3
Keywords: Cc:
Blocked By: Blocking:

Description

When tabbed to the form field on the dialog,the jaws announces the focused form field label as expected but along with that it also announces the dialog title bar components text.

Browser:IE8 screenReader:JAWS13

  1. Go to http://download.dojot oolkit.org/release-1.7.0/dojo-release-1.7.0/dijit/themes/themeTester.html
  2. Click on the dialogs in menu bar.
  3. Select the action bar.
  4. While JAWS is on,tab to the form fields on the dialog. [refer attached screenshot1]
  5. JAWS announces "Location Floating Modal Dialog cancel...".

Expected Result: Jaws should only announce the focused element.

Additional Info: The span elements inside div.dijitDialog are read along form fields.I see empty title="" tagged to the div.dijitDialog [refer attached screenshot2].When I remove this, JAWS announces the form field label properly ie.only the focused form field .Is there a purpose the empty title there?Can you please look at this issue?

This is not a issue in JAWS12 but started in JAWS13.

Change History (5)

comment:1 Changed 6 years ago by bill

Milestone: tbd1.8.4
Status: newassigned

The problem is actually in ContentPane. There's some code to clear the title attribute from the original DOMNode for declarative markup like:

<div dojoType=dijit/layout/ContentPane title="tab 1">

But the code instead sets title="", and to make matters worse, it does that even when no title was specified to begin with.

comment:2 Changed 6 years ago by bill

Resolution: fixed
Status: assignedclosed

In [30491]:

Fix how ContentPane removes the title attribute from this.domNode if it happens to be set.

Also, stop setting title attribute on Dialog.titleBar. It seems useless.

Fixes #16635 on trunk, !strict.

comment:3 Changed 6 years ago by bill

In [30492]:

Fix how ContentPane removes the title attribute from this.domNode if it happens to be set.

Fixes #16635 on 1.8 branch, !strict.

comment:4 Changed 6 years ago by bill

In [30504]:

Fix how ContentPane? removes the title attribute from this.domNode if it happens to be set.

Fixes #16635 on 1.7 branch, !strict.

comment:5 Changed 6 years ago by bill

Milestone: 1.8.41.7.5
Note: See TracTickets for help on using tickets.