Opened 6 years ago

Closed 6 years ago

#16634 closed defect (invalid)

Dialog: focus remains on editable div when opening a dojo modal dialog (Chrome)

Reported by: pagarwal Owned by: pagarwal
Priority: undecided Milestone: tbd
Component: Dijit Version: 1.8.3
Keywords: Cc:
Blocked By: Blocking:

Description

Issue only occurs on Chrome. Not sure if this is specific Dojo or Chrome bug. Will file an identical report on Chromium.

To reproduce the issue (I've tested on dojo 1.4.3, 1.6, 1.7 and 1.8.3):

  1. Navigate to http://demos.dojotoolkit.org/demos/themePreviewer/demo.html#
  1. On left side panel click on Popups and Alerts.
  1. On the page using the chrome dev tools inject a div with "contentEditable" set to true anywhere in the page.

<div contentEditable="true">Some Placeholder Text</div>

  1. Click into the field and type some text or leave the cursor as is
  1. Use the mouse to click on the "modal dialog w/action bar" link
  1. A loading dialog will popup, notice that the cursor remains in the editable div and you can continute typing within the div even though a dialog is being displayed. When the loading dialog changes to the actual dialog, you can still continue to type in the editable div. Until you explictly press tab to move focus to a focusable element in the dialog such as a input field or link etc.

Thanks, Piyush Agarwal

Change History (4)

comment:1 Changed 6 years ago by pagarwal

Sorry the title should say only for contentEditable div, but should also be verified for input and textarea fields.

Also fails in Safari 5 and 6, might be an issue with WebKit?.

Last edited 6 years ago by pagarwal (previous) (diff)

comment:2 Changed 6 years ago by bill

Component: GeneralDijit
Owner: set to bill
Summary: Chrome - Focus remains on input/textarea/editable div when opening a dojo modal dialog.Dialog: focus remains on editable div when opening a dojo modal dialog (Chrome)

If you are focused on an input or textarea, and click a button to open a dialog, focus first moves to the button, before moving to the dialog So there's no problem there. Not sure why that isn't happening with a contentEditable div.

comment:3 Changed 6 years ago by bill

Owner: changed from bill to pagarwal
Status: newpending

I'm not quite sure how to "inject a div with "contentEditable" using the chrome dev tools.

I did try to insert a <div contentEditable="true">Some Placeholder Text</div> into the the dijit/themes/themeTester.html test file itself. This is on the latest in the 1.8 branch. I didn't see the problem you are talking about though (testing on chrome/mac and chrome/win). Can you provide a simplified test file that reproduces the problem?

comment:4 Changed 6 years ago by trac-o-bot

Resolution: invalid
Status: pendingclosed

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

Note: See TracTickets for help on using tickets.