Opened 6 years ago

Closed 6 years ago

#16631 closed defect (fixed)

1.8 aria related failures

Reported by: haysmark Owned by: bill
Priority: undecided Milestone: 1.8.4
Component: Accessibility Version: 1.8.3
Keywords: Cc:
Blocked By: Blocking:

Description

I suspect these failures are caused by some of the robot tests being inconsistent with the underlying non-robot tests; we updated these tests in the recent a11y backport. These failures are common to both FF18 and Chrome 24.

    _AssertFailure: assertEqual() failed:
 	expected
		1
	but got
		0

 with hint: 
		date is selected
FAILED test: ../../dijit/tests/robot/Calendar_a11y.html::API::initialValue 0 ms
    Error: Cannot call method 'setAttribute' of undefined
FAILED test: ../../dijit/tests/robot/Calendar_a11y.html::aria:: 6 ms
    _AssertFailure: assertEqual() failed:
 	expected
		0
	but got
		-1

 with hint: 
		actual value is null
FAILED test: ../../dijit/tests/robot/Calendar_a11y.html::navigation::month navigation 4506 ms
     _AssertFailure: assertEqual() failed:
 	expected
		tabpanel
	but got
		null

 with hint: 
		containerNode child role
FAILED test: ../../dijit/tests/layout/robot/TabContainer_a11y.html::aria::tab container attributes 1 ms

Change History (5)

comment:1 Changed 6 years ago by haysmark

Owner: changed from mikeb to Douglas Hays
Status: newassigned

comment:2 Changed 6 years ago by Douglas Hays

Milestone: tbd1.8.4

In [30481], add gridNode attach point to _altCalendar template.

comment:3 Changed 6 years ago by Douglas Hays

Owner: changed from Douglas Hays to bill

Bill, can you look at the TabContainer? a11y issue? It's probably something to do with layout aria changes not being backported fully to 1.8.

comment:4 Changed 6 years ago by bill

Sure, I'll take a look.

comment:5 Changed 6 years ago by bill

Resolution: fixed
Status: assignedclosed

In [30482]:

Since the StackContainer wrapper changes from [29904] were (intentionally) not backported to 1.8, this part of the test changes from [30053] cannot be backported either, refs #16307, fixes #16631.

Note: See TracTickets for help on using tickets.