Opened 13 years ago

Closed 7 years ago

#1663 closed defect (fixed)

fix loader.js comments and function names

Reported by: bill Owned by: James Burke
Priority: low Milestone: 1.7
Component: Loader Version: 0.3
Keywords: needsreview Cc:
Blocked By: Blocking:

Description (last modified by James Burke)

As per the recent discussion to call dojo.html a module and dojo.html.common a resource... the comments and function/variable names in loader.js need to be updated. Here's a partial list of suggested updates:

  • rename private functions to have _ in front of them
  • rename loaded_modules --> loaded_resources
  • rename startPackage --> startModule, or roll startPackage() code into dojo.provide(); unclear if a separate function is needed. in any case the comment for the function is confusing because it talks about creating javascript objects, which is more of an implementation detail than a guaranteed api. (contrast w/the comment for dojo.provide)
  • rename findModule -> findResource
  • loadPath - the comment should say it loads resources, or at the least, it shouldn't use the word "modules"
  • modulesLoaded - could be resourcesLoaded? should probably have an underscore
  • signature for addOnLoad/addOnUnload is better written as function(/*Object?*/obj, /*String|Function*/functionName). The first argument is optional and the second is mandatory.

Change History (8)

comment:1 Changed 13 years ago by bill

Description: modified (diff)

comment:2 Changed 13 years ago by bill

See also #1544, basically a dup of this (but this bug shouldn't be closed because it has notes on the changes to make).

comment:3 Changed 12 years ago by James Burke

Milestone: 0.91.0

This should have been done as part of the initial 0.9 code porting, but I missed it. I'm not comfortable making all of the changes this close to a 0.9 RC candidate, so I'm pushing to 1.0. Even though these are API changes they are mostly on things that are considered private. But still, may be too risky to do even then. I'll consult with others after 0.9 gets pushed out.

comment:4 Changed 12 years ago by James Burke

Milestone: 1.02.0

Pushing this to 2.0, when we might have a chance to cause more disruption to the code.

comment:5 Changed 11 years ago by alex

Milestone: 2.01.3

Milestone 2.0 deleted

comment:6 Changed 11 years ago by James Burke

Description: modified (diff)
Milestone: 1.3future

comment:7 Changed 7 years ago by ben hockey

Keywords: needsreview added
Priority: highlow

is any of this still relevant with amd?

comment:8 Changed 7 years ago by bill

Component: GeneralLoader
Milestone: future1.7
Resolution: fixed
Status: newclosed

Probably not, I'll close.

Note: See TracTickets for help on using tickets.