Opened 6 years ago

Closed 4 years ago

#16628 closed defect (invalid)

dojo/JsonRest sends 'id' attribute on put/add to REST server even though idProperty is set to a different value

Reported by: n_mouli Owned by: n_mouli
Priority: undecided Milestone: 1.13
Component: Data Version: 1.8.3
Keywords: Cc:
Blocked By: Blocking:

Description

Hi, I am creating a dgrid/JsonRest UI and a REST Server backend for a tool that i am working on. I found that even though i specify idProperty to a different attribute in JsonRest? store configuration, when i trigger a put request from JsonRest? to my REST backend, the JSON object in the payload goes with an additional 'id:' attribute which is not only superfluous but also may break JSON deserialization as the 'id:' attribute is not expected to be present. I guess this needs to be fixed. Thanks, Chandramouli

Change History (4)

comment:1 Changed 6 years ago by bill

Component: GeneralData
Owner: set to Kris Zyp

comment:2 Changed 5 years ago by jmorrin

I cannot reproduce this problem.

Can you provide more detail?

  • A code example of how you are using the JsonRest? store.
  • Provide some test data from the backend service.

comment:3 Changed 4 years ago by dylan

Milestone: tbd1.12
Owner: changed from Kris Zyp to n_mouli
Status: newpending

comment:4 Changed 4 years ago by trac-o-bot

Resolution: invalid
Status: pendingclosed

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

Note: See TracTickets for help on using tickets.