Opened 6 years ago

Closed 6 years ago

#16610 closed defect (invalid)

pop-up teltale not attached to bubble window

Reported by: miker Owned by: miker
Priority: undecided Milestone: tbd
Component: Dijit Version: 1.8.1
Keywords: Cc:
Blocked By: Blocking:

Description (last modified by ben hockey)

download package says dojo-release-1.8.1.tar.gz

dijit/popup.js dijit/TooltipDialog.js

Bug #1 popup tell-tale (the little arrow attachment) is separated from the bubble by the "margin" offset". See attached screenshot1.jpg It appears that the margin is being applied to the bubble twice??

Bug #2 -- on context over dgrid-content popup tell-tale is not oriented correctly. See screenshot2.jpg tell-tale is always positioned to the left and below the bubble no matter where the right click occurs on the screen (dgrid-content)

with css like this

<link rel="stylesheet" href="lib/dojo/dijit/themes/claro/claro.css">
<link rel="stylesheet" href="lib/dojo/dgrid/css/skins/claro.css">
<link rel="stylesheet" href="lib/dojo/dgrid/css/dgrid.css">

#help {
  font-weight: normal;
  float: right;
  margin-right: 100px;
  display: inline-block;
}
#qmark {
  font-weight: bold;
  font-size: 1.2em;
}

and code like this

//bug 1
    on(dojo.byId('help'), 'mouseover', function() {
        popup.open({
            popup: helpTip,
            around: dom.byId('help'),
        });
    });

    helpTip = new TooltipDia({
        id: 'help',
        content: 'some help',
        onMouseLeave: function() {
            popup.close(helpTip);
        }
    });
  }

//bug 2
    grid.on('.dgrid-content:contextmenu', function(evt) {
        evt.preventDefault();
        popup.open({
            popup: helpTip,
            x: evt.pageX, 
            y: evt.pageY
        });;
    });



<body class=claro>
<div id="help"><span id="qmark">?&nbsp;</span>help</div>
<br clear='both'>
<div id="grid">
</div>

Attachments (2)

screenshot1.jpg (131.0 KB) - added by miker 6 years ago.
screenshot of bug #1
screenshot2.jpg (132.8 KB) - added by miker 6 years ago.
screenshot of bug #2

Download all attachments as: .zip

Change History (5)

Changed 6 years ago by miker

Attachment: screenshot1.jpg added

screenshot of bug #1

Changed 6 years ago by miker

Attachment: screenshot2.jpg added

screenshot of bug #2

comment:1 Changed 6 years ago by ben hockey

Description: modified (diff)

comment:2 Changed 6 years ago by bill

Owner: changed from bill to miker
Status: newpending

Please attach a test case using the "attach file" button. It should be as small as possible to still reproduce the problem, almost always a single HTML file that we can load in the browser (i.e. not PHP, JSP, etc.)

Then, give exact instructions on how to reproduce the problem using your attached test file.

The test case is necessary both to confirm that there's a bug, and for us to be able to debug the problem.

Thanks!

comment:3 Changed 6 years ago by trac-o-bot

Resolution: invalid
Status: pendingclosed

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

Note: See TracTickets for help on using tickets.