Opened 7 years ago

Closed 7 years ago

#16603 closed defect (invalid)

the programmatic example for GridLayout doesn't work as expected

Reported by: Sebastien Brunot Owned by: Eric Durocher
Priority: undecided Milestone: tbd
Component: DojoX Mobile Version: 1.8.3
Keywords: Cc:
Blocked By: Blocking:

Description

When using the programmatic example at the end of http://dojotoolkit.org/reference-guide/1.8/dojox/mobile/GridLayout.html#dojox-mobile-gridlayout, the buttons are displayed in a single row and not in a 3 columns grid as expected (tested on Google Chrome only).

I've attached a sample to reproduce quickly.

Attachments (2)

grid-layout.html (3.2 KB) - added by Sebastien Brunot 7 years ago.
theme-checking.patch (1.2 KB) - added by Sebastien Brunot 7 years ago.
Example of theme checking implementation

Download all attachments as: .zip

Change History (8)

Changed 7 years ago by Sebastien Brunot

Attachment: grid-layout.html added

comment:1 Changed 7 years ago by Sebastien Brunot

Component is "DojoX Mobile", not "General" my mistake.

comment:2 Changed 7 years ago by bill

Component: GeneralDojoX Mobile
Owner: set to Eric Durocher

comment:3 Changed 7 years ago by Eric Durocher

You need to include a theme, either explicitly (e.g. <link ... iphone.css">), or by loading deviceTheme.js before dojo.js. It could probably be made explicit, but then we need to do it for all dojox/mobile samples.

comment:4 Changed 7 years ago by Sebastien Brunot

Ok, this one is not a bug then.

Changed 7 years ago by Sebastien Brunot

Attachment: theme-checking.patch added

Example of theme checking implementation

comment:5 Changed 7 years ago by Sebastien Brunot

Maybe we could add a "theme checking" feature that will log a warning when starting a view if it seems that no dojox mobile themes has been loaded ? I've attached a patch with a naive implementation for this theme checking to explain what I mean.

comment:6 Changed 7 years ago by Eric Durocher

Resolution: invalid
Status: newclosed
Note: See TracTickets for help on using tickets.