Opened 7 years ago

Closed 4 years ago

Last modified 4 years ago

#16601 closed enhancement (fixed)

Cannot compile ES5 JS with closure compiler

Reported by: mhils Owned by: Rawld Gill
Priority: blocker Milestone: 1.11
Component: BuildSystem Version: 1.8.3
Keywords: Cc:
Blocked By: Blocking:

Description

I use ES5 getters and setters frequently in my code. However, closure compiler complains unless you invoke it with the --language_in ES5 option. Sadly there is now way to tell the build system to do so. an additional switch would be awesome (like .keeplines maybe).

My current workaround is to add

options.setLanguageIn(jscomp.CompilerOptions.LanguageMode.ECMASCRIPT5);

in writeOptimized.js#L100

Thanks!

Change History (7)

comment:1 Changed 7 years ago by Rawld Gill

Milestone: tbd1.9
Status: newassigned

comment:2 Changed 7 years ago by Rawld Gill

Priority: undecidedhigh
Type: defectenhancement

comment:3 Changed 6 years ago by bill

Milestone: 1.92.0

Since we released the beta for 1.9, presumably this enhancement should be bumped to 2.0.

comment:4 Changed 6 years ago by Rawld Gill

Resolution: duplicate
Status: assignedclosed

Duplicate of #16196.

comment:5 Changed 4 years ago by dylan

Milestone: 2.01.11
Priority: highblocker
Resolution: duplicate
Status: closedreopened

Per note in https://github.com/dojo/util/pull/27 , this blocks being able to compile to ES5 and is not a duplicate as previously reported.

comment:6 Changed 4 years ago by dylans <dylan@…>

Resolution: fixed
Status: reopenedclosed

In 72cb7fd661b7572cc54603d9233abcf1b39ceae3/util:

Error: Processor CommitTicketReference failed
Unsupported version control system "git": Can't find an appropriate component, maybe the corresponding plugin was not enabled? 

comment:7 Changed 4 years ago by dylans <dylan@…>

In 9d92e7014ae08af9717b251a113bc2f1cafe2d7e/util:

Error: Processor CommitTicketReference failed
Unsupported version control system "git": Can't find an appropriate component, maybe the corresponding plugin was not enabled? 
Note: See TracTickets for help on using tickets.