Opened 7 years ago

Closed 7 years ago

Last modified 6 years ago

#16573 closed defect (fixed)

_startSearchFromInput not triggered in Internet Explorer whene pasting values by ctrl + v

Reported by: Florian Owned by: Douglas Hays
Priority: undecided Milestone: 1.8.4
Component: Dijit - Form Version: 1.8.3
Keywords: Cc:
Blocked By: Blocking:

Description

Hi,

when pasting contents with ctrl + v to an input using dijit/form/_SearchMixin, at least in Internet Explorer 8 _startSearchFromInput() is not triggered. There is neither a problem with pasting by context-menue nor on other browsers.

The cause for this seems to be the fact that IE gets 'evt.ctrlKey == true' in both cases 'evt.type = "keydown"' AND 'evt.type = "paste"' - this causes _processInput to return before calling _startSearchFromInput.

My current workaround to this problem is to extend _SearchMixin and overwrite _processInput(evt) with following method:

_processInput: function(/*Event*/ evt){
    // XXX workaround for problem with IE and paste-event
    if (has('ie') && 'type' in evt && evt.type == 'paste') {
        evt.ctrlKey = false;
    }
    this.inherited(arguments);
}

Regards,

Florian

Change History (7)

comment:1 Changed 7 years ago by Douglas Hays

Milestone: tbd1.9
Status: newassigned

comment:2 Changed 7 years ago by Douglas Hays

Resolution: fixed
Status: assignedclosed

In [30529]:

Fixes #16573. Check for key event type before checking other key event attributes.

comment:3 Changed 7 years ago by Douglas Hays

In [30584]:

Refs #16573. dojox/mobile/SearchBox is sending faux events without type.

comment:4 Changed 6 years ago by Florian

Hi doughays,

sorry for late answer: I think this is a bugfix and should be backportet to at least 1.8.4.

I would reopen this ticket but for a reason I don't understand the only option I have is to 'leave [it] as closed'.

Regards,

Florian

comment:5 Changed 6 years ago by Douglas Hays

Milestone: 1.91.8.4

regression started in 1.8.

comment:6 Changed 6 years ago by Douglas Hays

In [31179]:

Refs #16573. Backport fix to 1.8.4 to support IE8.

comment:7 Changed 6 years ago by Douglas Hays

#17075 is a duplicate of this ticket.

Note: See TracTickets for help on using tickets.