Opened 6 years ago

Closed 6 years ago

#16556 closed defect (invalid)

exception in error reporting in dojo.js

Reported by: cbarlock Owned by: cbarlock
Priority: undecided Milestone: tbd
Component: Loader Version: 1.8.3
Keywords: Cc:
Blocked By: Blocking:

Description (last modified by bill)

Dojo 1.8.3 line 1831:

// now that req is fully initialized and won't change, we can hook it up to the error signal
on(error, function(arg){
try{
console.error(arg);
if(arg instanceof Error){
for(var p in arg){
console.log(p + ":", arg[p]);
}
console.log(".");
}
}catch(e){}
}); 

I have an example where colNumber and msgId in arg are both undefined, so the exception is thrown and the logging of useful information is aborted. If arg[p] is undefined the code should log "undefined" instead.

Change History (3)

comment:1 Changed 6 years ago by bill

Component: GeneralLoader
Description: modified (diff)
Owner: set to Rawld Gill

That's hard to believe, I tried this in FF and no exception:

var foo = {a: undefined};
console.log(foo.a);

comment:2 Changed 6 years ago by bill

Owner: changed from Rawld Gill to cbarlock
Status: newpending
Summary: dojo.js not handled properlyexception in error reporting in dojo.js

Please attach a test case using the "attach file" button. It should be as small as possible to still reproduce the problem, almost always a single HTML file that we can load in the browser (i.e. not PHP, JSP, etc.)

Then, give exact instructions on how to reproduce the problem using your attached test file.

The test case is necessary both to confirm that there's a bug, and for us to be able to debug the problem.

Thanks!

comment:3 Changed 6 years ago by trac-o-bot

Resolution: invalid
Status: pendingclosed

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

Note: See TracTickets for help on using tickets.