Opened 7 years ago

Closed 6 years ago

#16552 closed defect (patchwelcome)

Dialog: unable to drag scrollbars (IE9 in EmulateIE7 mode)

Reported by: Walter Higgins Owned by: bill
Priority: undecided Milestone:
Component: Dijit Version: 1.7.2
Keywords: Cc:
Blocked By: Blocking:

Description

See http://mail.dojotoolkit.org/pipermail/dojo-interest/2011-May/054779.html for details. The problem does not occur when a page is rendered in IE8 mode. Using dojo 1.7.2

Attachments (2)

dojo-diag3.html (5.6 KB) - added by Walter Higgins 6 years ago.
A file which demonstrates the ScrollBar? problem when using IE9 and 'Quirks Mode' is turned on.
dojo-diag3-dojo-18.html (5.5 KB) - added by Walter Higgins 6 years ago.
Example page using Dojo 1.8.3

Download all attachments as: .zip

Change History (12)

comment:1 Changed 7 years ago by bill

Component: Dijit - LnFDijit
Resolution: worksforme
Status: newclosed
Summary: IE9 in EmulateIE7 mode: Unable to drag scrollbars in dialogDialog: unable to drag scrollbars (IE9 in EmulateIE7 mode)

You didn't provide a test case. I set my IE9 browser mode to IE7, made my browser window fairly small, and then tried http://download.dojotoolkit.org/release-1.7.2/dojo-release-1.7.2/dijit/tests/test_Dialog.html, clicking the "Dialog w/embedded layout widgets" button. Scrolling works fine.

I'd suggest not using IE7 emulation mode though, sounds like you are asking for trouble.

comment:2 Changed 6 years ago by Walter Higgins

Hi Bill,

We are constrained to using an IE Embedded Pane (It's a .NET application) and we cannot change the compatibility mode from the default (IE7).

These are the relevant browser/page properties...

UserAgent? = Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 5.2; WOW64; Trident/4.0; .NET CLR 2.0.50727; .NET4.0C; .NET4.0E)

document.documentMode = 5

document.compatMode = BackCompat?

comment:3 Changed 6 years ago by bill

OK, perhaps you can use those parameters to come up with a standalone test case. If so, please attach one and write a comment back here.

Changed 6 years ago by Walter Higgins

Attachment: dojo-diag3.html added

A file which demonstrates the ScrollBar? problem when using IE9 and 'Quirks Mode' is turned on.

comment:4 Changed 6 years ago by Walter Higgins

So the problem is actually reproducible when you have a Dojo Dialog, a Dojo BorderContainer? inside that dialog and any content pane whose contents extend beyond the viewpane. To reproduce the problem with the attached file (dojo-diag3.html)...

  1. open the attached file in IE9 (probably best to put it in a web-accesssible folder on a webserver - dojo complains about file:// type urls)
  2. click on the 'Compatibility View' button (a button with a torn document icon, normally found to the right of the location field)
  3. Try to scroll the top pane by clicking and dragging the scrollbar's slider.

Expected result: Should be able to scroll. Actual result: The scrollbar slider cannot be moved by clicking and dragging the slider.

comment:5 Changed 6 years ago by bill

Resolution: worksforme
Status: closedreopened

OK, fair enough, thanks for the test case; I'll take a look.

comment:6 Changed 6 years ago by bill

Milestone: tbd1.8
Resolution: fixed
Status: reopenedclosed

I reproduce it. And it's fixed in 1.8, starting with [28386]. Not sure why though.

comment:7 in reply to:  6 Changed 6 years ago by Walter Higgins

Replying to bill:

I reproduce it. And it's fixed in 1.8, starting with [28386]. Not sure why though.

This problem still occurs in Dojo 1.8 . See the new attached file dojo-diag3-dojo_18.html. The problem is intermittent - the first time you drag the scrollbar slider it works but try it a couple of times, eventually the slider becomes unresponsive and may or may not work for any given drag of the slider.

Changed 6 years ago by Walter Higgins

Attachment: dojo-diag3-dojo-18.html added

Example page using Dojo 1.8.3

comment:8 Changed 6 years ago by Walter Higgins

I'd like this ticket to be re-opened. See example file attached.

comment:9 Changed 6 years ago by bill

Milestone: 1.8
Resolution: fixed
Status: closedreopened

OK, I do see it, so I remove the "fixed" status from this ticket, but it's not something I'm interested in working on since IE6 and IE7 are being desupported. If you have a patch we'd consider it.

comment:10 Changed 6 years ago by bill

Resolution: patchwelcome
Status: reopenedclosed
Note: See TracTickets for help on using tickets.