Opened 7 years ago

Closed 7 years ago

Last modified 6 years ago

#16550 closed defect (fixed)

[regression] Menu in a Dialog does not appear on right click

Reported by: cdabija Owned by: bill
Priority: undecided Milestone: 1.8.4
Component: Dijit Version: 1.8.2
Keywords: Cc:
Blocked By: Blocking:

Description

<div id="test">test</div>

<div data-dojo-type="dijit/Menu" id="context_menu_matd"

data-dojo-props="targetNodeIds: test?"

style="display:none;">

<!-- .... Menu Items .... -->

</div>

If this code is contained in a dijit/Dialog. Right click on the "test" div shows the menu for a brief period then disappear on mouse move. Second right click does not display anything with no error triggered.

If the code is not contained in a dialog then it works OK.

The problem appear only in 1.8.2 and 1.8.3. In 1.8.1 the code works ok in the dialog also.

Change History (8)

comment:1 Changed 7 years ago by bill

Milestone: tbd1.8.4
Status: newassigned
Summary: dijit/Menu in a dialog does not appear on right click[regression] Menu in a Dialog does not appear on right click

Yah, sorry about that, I broke it when fixing #15370.

comment:2 Changed 7 years ago by bill

Resolution: fixed
Status: assignedclosed

In [30290]:

Rollback [30001] and [30268], changes for restoring focus to Dialog when it's lost via a mouse click. Refs #15370 and fixes #16550 and #16551 on 1.6 branch, !strict.

comment:26 Changed 7 years ago by bill

In [30291]:

Rollback [30000] and [30269], changes for restoring focus to Dialog when it's lost via a mouse click. Refs #15370 and fixes #16550 and #16551 on 1.7 branch, !strict.

comment:27 Changed 7 years ago by bill

In [30292]:

Rollback [29999], changes for restoring focus to Dialog when it's lost via a mouse click. Refs #15370 and fixes #16550 and #16551 on 1.8 branch, !strict.

comment:28 Changed 6 years ago by bill

#16571 is a duplicate of this ticket.

comment:29 Changed 6 years ago by bill

In [30682]:

Fix problem when user presses "previous" button on iOS software keyboard and focus goes from Dialog back to main page. But take care not to break context menus on the Dialog: ignore focus events that occur on those menus. Fixes #15370, refs #16550 !strict.

comment:30 Changed 6 years ago by Bill Keese <bill@…>

In a252025f2e3f016c78230130192e61a434142d33/dijit:

Error: Processor CommitTicketReference failed
Unsupported version control system "git": Can't find an appropriate component, maybe the corresponding plugin was not enabled? 

comment:31 Changed 6 years ago by Bill Keese <bill@…>

In 31a52d41e341c17bc87891edb6103e9162d06204/dijit:

Error: Processor CommitTicketReference failed
Unsupported version control system "git": Can't find an appropriate component, maybe the corresponding plugin was not enabled? 
Note: See TracTickets for help on using tickets.