Opened 7 years ago

Closed 7 years ago

#16531 closed defect (invalid)

ymin ymax bug in dojox/charting/plot2d/common

Reported by: superdweebie Owned by: superdweebie
Priority: undecided Milestone: tbd
Component: Charting Version: 1.8.2
Keywords: Cc:
Blocked By: Blocking:

Description

If both ymin and ymax are set on a series, and no axies are specified, then hmin and hmax are not calculated (and they should be).

Patched file attached.

(this is an easy fix. I'd really appreciate if this could be in the master soonish)

Attachments (1)

common.js (7.4 KB) - added by superdweebie 7 years ago.
Patched source

Download all attachments as: .zip

Change History (5)

Changed 7 years ago by superdweebie

Attachment: common.js added

Patched source

comment:1 Changed 7 years ago by bill

Component: DojoxCharting
Owner: changed from Adam Peller to Eugene Lazutkin

It's much easier if you attach a patch file. If it's more than a few lines of changes though you need to file a CLA first, if you haven't already.

comment:2 Changed 7 years ago by cjolif

and also ideally a test case reproducing the issue to easily validate the patch. If needed for the CLA see here for signing: http://dojofoundation.org/about/cla

comment:3 Changed 7 years ago by cjolif

Owner: changed from Eugene Lazutkin to superdweebie
Status: newpending

superdweebie any news on testcase & .patch file?

comment:4 Changed 7 years ago by trac-o-bot

Resolution: invalid
Status: pendingclosed

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

Note: See TracTickets for help on using tickets.