Opened 6 years ago

Closed 6 years ago

#16527 closed defect (duplicate)

TabContainer: ignores doLayout=false when ContentPane contains single TabContainer with doLayout=false

Reported by: milad Owned by: bill
Priority: undecided Milestone: tbd
Component: Dijit Version: 1.8.3
Keywords: Cc:
Blocked By: Blocking:

Description

hi all
if i have TabContainer? with doLayout="false" and ContentPane?'s content load from external page and it have TabContainer? with doLayout="false",parent TabContainer? show scroll.
before 1.8.x i put <br> tag on the first line of content.(line 1 content.html),but in 1.8.x versions this problem not solve by <br>.
sorry for my poor language

Attachments (2)

content.html (479 bytes) - added by milad 6 years ago.
tab.html (747 bytes) - added by milad 6 years ago.

Download all attachments as: .zip

Change History (5)

Changed 6 years ago by milad

Attachment: content.html added

Changed 6 years ago by milad

Attachment: tab.html added

comment:1 Changed 6 years ago by bill

Resolution: patchwelcome
Status: newclosed
Summary: TabContainer: ignoring doLayout=false when ContentPane have TabContainer with doLayout=falseTabContainer: ignores doLayout=false when ContentPane contains single TabContainer with doLayout=false

You can get this to work by setting doLayout=false on the ContentPane too.

The problem happens because the ContentPane has a single child widget, and it tries to size that child widget.

I agree it's confusing, but I'm skeptical there's anything that we can do to solve the problem better than requiring the user to manually set doLayout=false on the ContentPane

comment:2 Changed 6 years ago by bill

Resolution: patchwelcome
Status: closedreopened

comment:3 Changed 6 years ago by bill

Resolution: duplicate
Status: reopenedclosed

Duplicate of #8197.

Note: See TracTickets for help on using tickets.