Opened 6 years ago

Closed 6 years ago

#16517 closed defect (fixed)

[regression] Dialog: wrong "calculation of focus lost" on Dialog with iframe

Reported by: iamFake Owned by: bill
Priority: high Milestone: 1.8.4
Component: Dijit Version: 1.8.3
Keywords: Cc:
Blocked By: Blocking:

Description (last modified by bill)

Changesets [29823] and [29999] represent a mechanism for the return of focus "If focus is accidentally lost from a Dialog" - but its algorithm is wrong. If inside the dialog will be iframe - his becomes unusable (click on iframe and focus instantly moves to the first element).

Change History (3)

comment:1 Changed 6 years ago by bill

Description: modified (diff)
Milestone: tbd1.9
Status: newassigned
Summary: wrong "calculation of focus lost"Dialog: wrong "calculation of focus lost" on Dialog with iframe

Whenever an application creates an iframe that can be focused by the user (i.e. that has focusable/clickable controls), the application is supposed to register the iframe via dijit/focus::registerIframe(frame).

This has actually been a requirement since version 1.0 or earlier, but admittedly it's become much more essential to do after the above changesets.

I'd be happy to eliminate the requirement but not sure how. Perhaps a ContentPane could scan for iframes in it's content and register them automatically. I'll see if that works.

comment:2 Changed 6 years ago by bill

Priority: undecidedhigh

comment:3 Changed 6 years ago by bill

Milestone: 1.91.8.4
Resolution: fixed
Status: assignedclosed
Summary: Dialog: wrong "calculation of focus lost" on Dialog with iframe[regression] Dialog: wrong "calculation of focus lost" on Dialog with iframe

I rolled back [29999] (from the 1.8 branch), and I'll deal with the iframe issue somehow on trunk under #15370. Closing this ticket in preference to #15370.

Note: See TracTickets for help on using tickets.