Opened 7 years ago

Closed 6 years ago

#16511 closed defect (fixed)

View's usage of _TemplatedMixin means that dojox.mvc.Output doesn't work with the default expression character

Reported by: itamar Owned by: Ed Chatelain
Priority: undecided Milestone: 1.9
Component: DojoX MVC Version: 1.8.2
Keywords: Cc:
Blocked By: Blocking:

Description

Since the default expression character is "$", by default it doesn't work and throws an error in _TemplatedMixin (line ~ 80, { throw new Error(className+" template:"+key); } ) . Of course, if the expression character is set to something different, it works well.

Now, since dojox.mvc.Output is very likely to be often used with the dojox.app framework, IMHO this is rather confusing and should either be fixed or documented appropriately (this is not currently mentioned in the reference docs of dojox.mvc.Output)...

@cjolif commented:

The problem I think will arise in Dijit tempates as well. This is caused by $ being a special char in Dijit templates mechanism that we leverage. In 2.0 dojox/mvc should probably be change to use a different default. I think a enhancement request should be opened on dojox/mvc and this item should be closed because there is nothing we can do on dojox/app side here.


See original report here: https://github.com/dmachi/dojox_application/issues/103

Moved here by @cjolif's request.

Change History (2)

comment:1 Changed 6 years ago by Ed Chatelain

In [30884]:

Better in-line doc for exprchar, refs #16511. !strict Thanks Akira Sudoh (IBM, CCLA).

comment:2 Changed 6 years ago by Ed Chatelain

Milestone: tbd1.9
Resolution: fixed
Status: newclosed

We have updated the doc to be clear about the potential conflict, we do not want to change the default char.

Note: See TracTickets for help on using tickets.