Opened 6 years ago

Closed 6 years ago

#16509 closed defect (invalid)

Charting click events for plot markers sometimes gets discarded

Reported by: ddumont Owned by: Eugene Lazutkin
Priority: undecided Milestone: tbd
Component: Charting Version: 1.8.3
Keywords: Cc:
Blocked By: Blocking:

Description

I've set up a simple function in my chart:

chart.connectToPlot('default', function(args) {

console.log(args.type); if (args.type == 'onclick') {

var shape = args.shape; debugger;

}

});

and what I notice is that if I press my mouse down on the center of a plot marker and am very careful not to move my mouse even a smidge... and release the mouse button, the onclick will fire and my debugger will pause.

However, if I click down on the center and move the mouse in any direction while staying within the marker, the mouse events get cancelled and onclick will never fire. some plot reset events get triggered and onmouseover will eventually get called after the mouse is released.

This is causing some ux issues with touchy mouses like mine... sometimes clicks do not register.

Change History (6)

comment:1 Changed 6 years ago by ddumont

More info: I'm using the claro theme, and I've tried in IE, FF, and Chrome

comment:2 Changed 6 years ago by cjolif

as far as I can see the _PlotEvents onclick is just the regular mouse click event. I don't think we should try to be smarter than the browser?

comment:3 Changed 6 years ago by ddumont

I dunno there's definitely something fishy going on here. It seems that using the dojox/charting/action2d/Magnify plugin helps visualize the problem... I know that my mouse is perfectly still and sometimes when I click on the marker to fire a click event it ignores it and just replays the animation.

comment:4 Changed 6 years ago by cjolif

ddumont do you have a full test-case including the use of Magnify?

comment:5 Changed 6 years ago by ddumont

Of course it's going to make a liar out of me now. I'm sorry to waste your time. Perhaps it was another dijit I was using causing focus issues or something.

I can't reproduce it anymore.

comment:6 Changed 6 years ago by cjolif

Resolution: invalid
Status: newclosed

ok, then let's close it and if you happen to reproduce at some point come back here ;)

Note: See TracTickets for help on using tickets.