Opened 7 years ago

Closed 7 years ago

Last modified 6 years ago

#16500 closed defect (invalid)

Tree: expansion is extremely slow when TreeStoreModel.loadItem() calls newItem()

Reported by: VictorWang Owned by: VictorWang
Priority: undecided Milestone: tbd
Component: Dijit Version: 1.8.2
Keywords: Cc:
Blocked By: Blocking:

Description

Dojo Version: 1.8.2 Description: Steps to reproduce

  1. Download the attached file, open test_Tree.html in browser (firefox for example)
  2. Click to expand "Asia", firefox hangs for a while and unresponsive script warning pops up.

Attachments (2)

test_Tree.html (2.5 KB) - added by VictorWang 7 years ago.
countries1.json (174 bytes) - added by VictorWang 7 years ago.
Put these 2 files in same directory

Download all attachments as: .zip

Change History (5)

Changed 7 years ago by VictorWang

Attachment: test_Tree.html added

Changed 7 years ago by VictorWang

Attachment: countries1.json added

Put these 2 files in same directory

comment:1 Changed 7 years ago by bill

Owner: changed from bill to VictorWang
Status: newpending
Summary: dijit.Tree expansion is extremely slowTree: expansion is extremely slow when TreeStoreModel.loadItem() calls newItem()

This looks very strange how your continentStore.loadItem() calls _store.newItem() 500 times. TreeStoreModel responds to every new item by requerying the list of children for that item's parent (see TreeStoreModel.onNewItem). So, you should stop calling _newItem() from loadItem().

Also, eventually you should stop using the deprecated TreeStoreModel and use ObjectStoreModel instead.

If you still have problems after that let us know.

Last edited 7 years ago by bill (previous) (diff)

comment:2 Changed 7 years ago by trac-o-bot

Resolution: invalid
Status: pendingclosed

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

comment:3 Changed 6 years ago by bill

See #17282 for discussion/solution, assuming this is the same problem as listed there.

Note: See TracTickets for help on using tickets.