Opened 13 years ago

Closed 12 years ago

#1650 closed defect (fixed)

When Title pane is child of content pane, IE doesn't show the contents after close/open

Reported by: guest Owned by: koranteng
Priority: high Milestone: 0.9
Component: Widgets Version: 0.4
Keywords: titlepane contentpane ie Cc:
Blocked By: Blocking:

Description

This issue is in the trunk. To reproduce: add following code to test_LayoutContainer.html in the inner left content pane. <div dojoType="TitlePane?" label="Reach out" labelNodeClass="rightpanelabel" containerNodeClass="rightpanecontent">

<form id="FindForm?" method="post" action="">

<p><input type="text" style="width:110px" name="place"/></p> <button dojoType="Button" id="find1" value="Find">Find</button>

</form>

</div> In IE, it shows the title pane properly. Click on it to close, works fine. Click on it again to open it, it doesn't show the contents in title pane. Any action you do on the screen, like selecting value from a different list box (foo), displays contents in title pane. It works properly in firefox. Please contact me at anil@… for more details.

Change History (3)

comment:1 Changed 13 years ago by bill

Milestone: 0.5

I can reproduce the problem as per your testcase; problem occurs in wipeIn() onEnd handler, which sets the height of the element back to it's original value (""), rather than an explicit value like "60px". This seems to trigger an IE bug.

Not sure how to fix it. Setting height to either "" or null or "auto" triggers the bug. I could leave the height set to "60px", but then if the TitlePane?'s content changes, the height won't change correspondingly.

comment:2 Changed 12 years ago by koranteng

Owner: changed from bill to koranteng

comment:3 Changed 12 years ago by koranteng

Resolution: fixed
Status: newclosed

I can't reproduce this in the trunk and tracked this down to be indirectly fixed in [6158] see #1605

Note: See TracTickets for help on using tickets.