Opened 7 years ago

Closed 7 years ago

Last modified 6 years ago

#16491 closed defect (fixed)

[regression] Error when mouse over dijit/MenuSeparator

Reported by: Jason Cowley Owned by: bill
Priority: high Milestone: 1.8.3
Component: Dijit Version: 1.8.2
Keywords: Cc:
Blocked By: Blocking:

Description

When hovering the mouse over a dijit/MenuSeparator I get the following error in the JavaScript? console (tested on Chrome):

Uncaught TypeError?: Object [Widget dijit.MenuSeparator?, separator] has no method 'focus'

dijit/_MenuBase is calling focusChild() in onItemHover without checking if the child is focusable.

This can be seen in the test page dijit/tests/test_Menu.html.

Change History (4)

comment:1 Changed 7 years ago by bill

Milestone: tbd1.8.3
Priority: undecidedhigh
Status: newassigned
Summary: Error when mouse over dijit/MenuSeparator[regression] Error when mouse over dijit/MenuSeparator

Argh, must be fallout from #16426.

Last edited 7 years ago by bill (previous) (diff)

comment:2 Changed 7 years ago by bill

Resolution: fixed
Status: assignedclosed

In [30216]:

Quick fix to avoid exception when mousing over MenuSeparator, fixes #16491 on 1.8 branch !strict.

comment:3 Changed 7 years ago by bill

In [30234]:

Quick fix to avoid exception when mousing over MenuSeparator?, fixes #16491, refs #16426 on trunk !strict.

comment:4 Changed 6 years ago by bill

#17313 is a duplicate of this ticket.

Note: See TracTickets for help on using tickets.