Opened 7 years ago

Closed 6 years ago

Last modified 6 years ago

#16490 closed defect (fixed)

dojox/mobile: on iOS6, some apps sometimes don't resize as expected when changing the device orientation

Reported by: Adrian Vasiliu Owned by: Eric Durocher
Priority: undecided Milestone: 1.8.4
Component: DojoX Mobile Version: 1.8.2
Keywords: Cc:
Blocked By: Blocking:

Description

At least with an app using dojox/mobile/ScreenSizeAware and dojox/mobile/FixedSplitter, when running on iOS 6 devices (iPad and iPhone), the app sometimes doesn't resize itself as expected after changing the device orientation.

How to reproduce:

  1. Load

http://download.dojotoolkit.org/release-1.8.2/dojo-release-1.8.2/dojox/mobile/tests/test_ScreenSizeAware-prop.html on an iOS 6 device (reproduced on iPad 4 iOS 6.0.1 and iPhone 4S iOS 6.0.1).

  1. Change the orientation of the device a number of times

=> After some number of orientation changes (sometimes after 15-20 turns, sometimes earlier), the app doesn't resize itself to adjust to the device orientation.

Workaround: Turn the device again (back and forth).

Remarks:

  • Also holds for Dojo 1.8.1, but not for 1.8.0.
  • Apparently it is a side-effect with the iOS6-specific changes in dojox/mobile/common (disabling these fixes the issue).
  • It doesn't seem related with how fast you turn the device (I also reproduced while turning slowly).
  • Did not reproduce on iPad 2 iOS 5.1.
  • Unclear whether it specific to the ScreenSizeAware / FixedSplitter used in this test. With a few other samples I did not reproduce (yet?) a similar issue.

The issue has been raised in http://dojo-toolkit.33424.n3.nabble.com/First-orientation-not-detected-in-dojox-mobile-tt3992117.html

Change History (4)

comment:1 Changed 7 years ago by Adrian Vasiliu

After further tests, it seems the issue is specific to dojox/mobile/ScreenSizeAware. The iOS6-specific changes in dojox/mobile/common (full-screen support) apparently make it hurt more often, but I also reproduced on iPhone 4S iOS 6.0.1 with the same test in Dojo 1.8.0 (http://download.dojotoolkit.org/release-1.8.0/dojo-release-1.8.0/dojox/mobile/tests/test_ScreenSizeAware-prop.html ), that is before the changes for full-screen support.

On the other side, I did NOT reproduce (after many attempts) with a test using FixedSplitter but NOT using ScreenSizeAware: http://download.dojotoolkit.org/release-1.8.2/dojo-release-1.8.2/dojox/mobile/tests/test_FixedSplitter-H2.html .

Hence, I suggest rephrasing the title of the ticket as follows: dojox/mobile: on iOS6, some apps using dojox/mobile/ScreenSizeAware sometimes don't resize as expected when changing the device orientation

ScreenSizeAware being marked experimental, and unless the issue will be reproduced without ScreenSizeAware, I would think the severity of this issue is low. Of course, this doesn't mean it doesn't deserve to be fixed, it is just an estimate of the impact.

Last edited 7 years ago by Adrian Vasiliu (previous) (diff)

comment:2 Changed 6 years ago by Adrian Vasiliu

This issue appears to go away thanks to the new ios6 full-screen support introduced in #16658. So this ticket can be closed when #16658 will be closed.

comment:3 Changed 6 years ago by cjolif

Resolution: fixed
Status: newclosed

comment:4 Changed 6 years ago by bill

Milestone: tbd1.8.4
Note: See TracTickets for help on using tickets.