Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#16487 closed defect (fixed)

[regression] the build tool is broken on osx

Reported by: ben hockey Owned by: Rawld Gill
Priority: blocker Milestone: 1.8.3
Component: BuildSystem Version: 1.8.2
Keywords: Cc:
Blocked By: Blocking:

Description

r30138 broke the build system when being used on "darwin"

has.add("is-windows", /win/.test(process.platform));

it doesn't take much to join the dots on this one... darwin is not windows.

this was found in the 1.8.2 release

Change History (7)

comment:1 Changed 7 years ago by ben hockey

Milestone: tbd1.8.3
Priority: undecidedblocker

comment:2 Changed 7 years ago by Colin Snover

Status: newassigned
Version: 1.8.2rc11.8.2

comment:3 Changed 7 years ago by Kitson Kelly

According to the documentation there is a limited list of valid values that are returned. My opinion is we should stick to documented values and this should be:

has.add("is-windows", process.platform == "win32");

Instead of getting "fancy" and not anchoring our RegEx or predicting what might be returned in the future.

comment:4 Changed 7 years ago by Patrick Ruzand

Oh sh.... I totally missed the darwin use case.. I first thought to change the test to ^win, but indeed you are right, a stricter 'win32' seems better, since it is documented...

Last edited 7 years ago by Patrick Ruzand (previous) (diff)

comment:5 Changed 7 years ago by Patrick Ruzand

FYI, I attached a new patch for trunk (since node.js support on windows has not been commited yet in trunk) to #15413

comment:6 Changed 7 years ago by Kitson Kelly

Resolution: fixed
Status: assignedclosed

In [30217]:

adjust has detection for windows under node, fixes #16487 !strict

comment:7 Changed 7 years ago by Colin Snover

Summary: the build tool is broken on osx[regression] the build tool is broken on osx
Note: See TracTickets for help on using tickets.