Opened 7 years ago

Closed 5 years ago

#16478 closed defect (wontfix)

sIEve reports memory leaks

Reported by: bill Owned by: haysmark
Priority: high Milestone: 1.10
Component: HTML Version: 1.8.1
Keywords: Cc:
Blocked By: Blocking:

Description (last modified by bill)

Starting with [30096], sIEve is reporting memory leaks on IE. Not sure if there's an actual leak but it's certainly a red flag. To reproduce:

  1. install and start sIEve, and load attached test case "t.html".
  2. click "clear in use"
  3. click "create dom node"
  4. click "destroy dom node"
  5. click "show in use"

The original test case I noticed this in was for #16439, which shows many leaked objects, but this reduced test case seems to capture the essence of the problem.

Attachments (3)

t.html (1.7 KB) - added by bill 7 years ago.
smallest test case
tabcontainer_leak.html (3.1 KB) - added by bill 7 years ago.
more elaborate test case
memoryleak.html (536 bytes) - added by haysmark 7 years ago.
Non-dojo test case.

Download all attachments as: .zip

Change History (10)

Changed 7 years ago by bill

Attachment: t.html added

smallest test case

Changed 7 years ago by bill

Attachment: tabcontainer_leak.html added

more elaborate test case

comment:1 Changed 7 years ago by bill

Description: modified (diff)
Milestone: tbd1.9
Owner: changed from Eugene Lazutkin to Douglas Hays
Status: newassigned

comment:2 Changed 7 years ago by bill

Description: modified (diff)

comment:3 Changed 7 years ago by Douglas Hays

Owner: changed from Douglas Hays to haysmark
Priority: undecidedhigh

haysmark, please investigate.

Changed 7 years ago by haysmark

Attachment: memoryleak.html added

Non-dojo test case.

comment:4 Changed 7 years ago by haysmark

See my simple non-Dojo test case, which experiences the same issue. See also #2931.

I thought maybe sIEve was incrementing the reference count one too many times but thus far I can't find any evidence of that. It seems very suspicious it has to add extra code to handle innerHTML being set, I almost wonder if it is just missing removeChild somehow.

comment:5 Changed 7 years ago by bill

Hmm, OK, so if sIeve is giving a false error I'm not sure what to do. We could either close this ticket and every future sIeve ticket with the same theme as wontfix, or add workaround code to dojo just to avoid the spurious sieve errors.

comment:6 Changed 6 years ago by bill

Milestone: 1.91.10

Bumping this ticket since we are past the deadline for the 1.9RC. The fix can be put into 1.9.1 too, if desired.

comment:7 Changed 5 years ago by dylan

Resolution: wontfix
Status: assignedclosed

I don't believe this is a valid issue, so closing it out.

Note: See TracTickets for help on using tickets.