Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#16473 closed defect (fixed)

[regression] _HasDropDown requires a focusNode

Reported by: freddefisk Owned by: bill
Priority: undecided Milestone: 1.8.3
Component: Dijit Version: 1.8.1
Keywords: Cc:
Blocked By: Blocking:

Description

The _HasDropDown.postCreate method throws an exception if focusNode is not defined. This was not the case in 1.7. Here is a jsfiddle to reproduce the error: http://jsfiddle.net/s7aaX/

Try changing the version in the drop down to 1.8.1 and check the error log.

Change History (6)

comment:1 Changed 6 years ago by bill

Milestone: tbd1.8.3

Thanks, I'll fix.

FYI, my tests against 1.7 (I modified your fiddle a bit) show that if this.focusNode wasn't defined, the drop down worked via mouse (and presumably touch event), but not via keyboard.

comment:2 Changed 6 years ago by bill

Resolution: fixed
Status: newclosed

In [30185]:

Fix regression where _HasDropDown subclass can no longer be defined unless it sets this.focusNode. Also adding rudimentary test file for _HasDropDown (although it's already tested extensively via the test files for subclasses like ComboBox). Fixes #16473 on trunk, !strict.

comment:3 Changed 6 years ago by bill

In [30186]:

Fix regression where _HasDropDown subclass can no longer be defined unless it sets this.focusNode. Also adding rudimentary test file for _HasDropDown (although it's already tested extensively via the test files for subclasses like ComboBox). Fixes #16473 on 1.8 branch, !strict.

comment:4 Changed 6 years ago by bill

In [30239]:

remove reference to test file that doesn't exist in 1.8, accidentally added in [30186], refs #16473

comment:5 Changed 6 years ago by bill

In [30798]:

Fix test failure on chrome. The mouseup event has to bubble because _HasDropDown sets a mouseup listener on the document. Refs #16473.

comment:6 Changed 6 years ago by bill

In [30799]:

Fix test failure on chrome when "emulate touch events" is turned on. The mouseup event has to bubble because _HasDropDown sets a mouseup listener on the document. Refs #16473.

Note: See TracTickets for help on using tickets.