Opened 7 years ago

Closed 7 years ago

#16472 closed defect (wontfix)

"name" attribute missing from object and embed elements created by dojox.embed.Flash

Reported by: Vicente Jiménez Aguilar Owned by: Tom Trenka
Priority: undecided Milestone: tbd
Component: Dojox Version: 1.8.1
Keywords: Cc:
Blocked By: Blocking:

Description

"name" attribute is missing from object and embed elements created with dojox.embed.Flash.

As documented in http://helpx.adobe.com/flash/kb/flash-object-embed-tag-attributes.html It is recommended to include both "id" and "name" with the same value.

dojox.embed.Flash only includes "id" and misses "name".

I found this problem because I was using a flash component that uses ExternalInterface?.objectID to identified itself when calling back javascript global functions.

The problem is that apparently ExternalInterface?.objectID only gets initialized by the "name" attribute.

With dojox.embed.Flash there is no way to include this. I have even tried to include it adding a "name" attribute to the widget but not all attributes are used to "generate" the tag. So "name" finally wasn't included in the falsh tag (object or embed)

Change History (2)

comment:1 Changed 7 years ago by Adam Peller

Owner: changed from Adam Peller to Tom Trenka
Status: newassigned

comment:2 Changed 7 years ago by Colin Snover

Resolution: wontfix
Status: assignedclosed

dojox/embed is abandoned.

Note: See TracTickets for help on using tickets.