Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#16458 closed defect (invalid)

Select: Need to ESC twice to close the listbox when Jaws run

Reported by: XiaoLei Owned by: Douglas Hays
Priority: undecided Milestone: tbd
Component: a11y - review Version: 1.8.1
Keywords: Cc: mikeb
Blocked By: Blocking:

Description

Please see the screenshot. If you want to close this listbox, you have to press ESC twice when Jaws run. But other listbox doesn't have this problem.

Attachments (1)

screenshot.png (15.1 KB) - added by XiaoLei 7 years ago.

Download all attachments as: .zip

Change History (7)

Changed 7 years ago by XiaoLei

Attachment: screenshot.png added

comment:1 Changed 7 years ago by bill

Component: GeneralDijit - Form
Owner: set to Douglas Hays
Summary: Need to ESC twice to close the listbox when Jaws runSelect: Need to ESC twice to close the listbox when Jaws run

Hmm, but it works fine normally right? I have no idea why jaws would cause that problem or how to fix it.

comment:2 Changed 7 years ago by Douglas Hays

Cc: mikeb added

mikeb, any ideas?

comment:3 Changed 7 years ago by mikeb

Hello, thanks for bringing this to my attention. I tested with the nightly build and JAWS13/14 and found that this behavior exists for all Select dijits, not just the rich text one. However, I think that this may actually be the expected behavior for JAWS. It seems that ESCAPE key should only be used by JAWS users to switch out of "Forms" mode - this is why when you push ESCAPE JAWS makes a beep and says "Virtual PC Cursor" (it is changing modes.) I have queried our experts internally to verify that my understanding is correct - when they confirm that this is JAWS expected behavior I will comment back and close this ticket.

comment:4 Changed 7 years ago by mikeb

Resolution: invalid
Status: newclosed

Hello. It turns out that this is actually a JAWS bug. My contact with Freedom Scientific is out this week, but I will post here with the bug report number when the bug gets made. Thanks for bringing this to our attention.

There is nothing that the Dojo team can do on our end to address this bug, so I've closed the ticket as "invalid." I will continue to post on this ticket with the progress from Freedom Scientific.

comment:5 Changed 7 years ago by bill

I'm surprised, because your first description about "expected behavior" made sense to me.

comment:6 Changed 7 years ago by mikeb

Component: Dijit - Forma11y - review

Hello. I just wanted to report that FS has opened Bug Report #307 to track this issue. I can post back when it gets resolved on their end.

Note: See TracTickets for help on using tickets.