Opened 6 years ago

Closed 6 years ago

#16450 closed defect (invalid)

Focus can not move on the main menu

Reported by: XiaoLei Owned by: XiaoLei
Priority: undecided Milestone: tbd
Component: Dijit Version: 1.8.1
Keywords: Cc:
Blocked By: Blocking:

Description

Arrow right/left on main menu. Focus go to sub level menu directly. Focus couldn't keep on the main menu. And when open Jaws, Jaws just read sub level menu item but not read main menu item.

Attachments (1)

ScreenShot.png (16.3 KB) - added by XiaoLei 6 years ago.
screenshot

Download all attachments as: .zip

Change History (3)

Changed 6 years ago by XiaoLei

Attachment: ScreenShot.png added

screenshot

comment:1 Changed 6 years ago by bill

Component: GeneralDijit
Owner: set to XiaoLei
Status: newpending

If the Edit menu is opened and you press the right arrow, then focus is supposed to advance to the first item of the View menu. Is that what you are talking about? It's intended behavior.

Otherwise, please attach a test case using the "attach file" button. It should be as small as possible to still reproduce the problem, almost always a single HTML file that we can load in the browser (i.e. not PHP, JSP, etc.).

Then, give exact instructions on how to reproduce the problem using your attached test file.

The test case is necessary both to confirm that there's a bug, and for us to be able to debug the problem.

Alternately, you can provide instructions to reproduce the problem using dijit's own test_Menu.html test file.

Thanks!

Last edited 6 years ago by bill (previous) (diff)

comment:2 Changed 6 years ago by trac-o-bot

Resolution: invalid
Status: pendingclosed

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

Note: See TracTickets for help on using tickets.