Opened 7 years ago

Closed 7 years ago

#16420 closed defect (duplicate)

--optimize comments --copyTests true broken (debugger statement)

Reported by: bill Owned by: Rawld Gill
Priority: undecided Milestone: tbd
Component: BuildSystem Version: 1.8.1
Keywords: Cc:
Blocked By: Blocking:

Description

Running a command like

./build.sh --release --profile profiles/webkitMobile.profile.js --copyTests true --optimize comments

gets the error:

error(356) The optimizer threw an exception; the module probably contains syntax errors. module identifier: /ws/webkitBuild/util/doh/runner.js; exception: (compile time:0.004s). OPTIMIZER FAILED: JavaException?: java.lang.RuntimeException?: Token: 159

The problem is that the comments "optimizer" doesn't like the "debugger" statement in util/doh/runner.js, but it is there on purpose:

if (doh.breakOnError) {
	debugger;
}

Change History (1)

comment:1 Changed 7 years ago by bill

Resolution: duplicate
Status: newclosed

Duplicate of #15789.
Oh, I filed this already.

Note: See TracTickets for help on using tickets.