Opened 7 years ago

Closed 7 years ago

#16417 closed defect (duplicate)

Support enforceDefine to detect IE 6 - 8 script.onerror issues.

Reported by: kr1zmo Owned by:
Priority: undecided Milestone: tbd
Component: General Version: 1.8.1
Keywords: Cc:
Blocked By: Blocking:

Description

Dojo uses a very similar appeal to requirejs; Here is the documentation on how requirejs fixed this issue. http://requirejs.org/docs/api.html#ieloadfail

It gets around this persistant issue by adding the enforceDefine property on the configuration object. When enforceDefine: true all modules loaded must call define(); requirejs uses that define call to fire an event and determine if the script was loaded. I highly suggest supporting this feature as IE cannot determine if a script was loaded when the response header wasn't 200.

Change History (1)

comment:1 Changed 7 years ago by bill

Resolution: duplicate
Status: newclosed

Duplicate of #16416.

Note: See TracTickets for help on using tickets.