Opened 6 years ago

Closed 6 years ago

#16416 closed defect (fixed)

Support enforceDefine to detect IE 6 - 8 script.onerror issues.

Reported by: kr1zmo Owned by: Rawld Gill
Priority: undecided Milestone: 1.9
Component: Loader Version: 1.8.1
Keywords: Cc:
Blocked By: Blocking:

Description

Dojo uses a very similar appeal to requirejs; Here is the documentation on how requirejs fixed this issue. http://requirejs.org/docs/api.html#ieloadfail

It gets around this persistant issue by adding the enforceDefine property on the configuration object. When enforceDefine: true all modules loaded must call define(); requirejs uses that define call to fire an event and determine if the script was loaded. I highly suggest supporting this feature as IE cannot determine if a script was loaded when the response header wasn't 200.

Attachments (1)

t16416.html (2.2 KB) - added by Rawld Gill 6 years ago.
usage example

Download all attachments as: .zip

Change History (5)

comment:1 Changed 6 years ago by bill

#16417 is a duplicate of this ticket.

comment:2 Changed 6 years ago by bill

Component: GeneralLoader
Owner: set to Rawld Gill

comment:3 Changed 6 years ago by Rawld Gill

Milestone: tbd1.9
Status: newassigned

comment:4 Changed 6 years ago by Rawld Gill

Resolution: fixed
Status: assignedclosed

In [30927]:

add enforceDefine functionality similar to requirejs via the has feature dojo-enforceDefine; see sample usage on ticket; fixes #16416; !strict

Changed 6 years ago by Rawld Gill

Attachment: t16416.html added

usage example

Note: See TracTickets for help on using tickets.