Opened 13 years ago

Closed 13 years ago

Last modified 12 years ago

#1641 closed defect (fixed)

Wrong checked propery in Checkbox widget

Reported by: miksir@… Owned by: bill
Priority: high Milestone:
Component: Widgets Version: 0.3
Keywords: Cc:
Blocked By: Blocking:

Description

  1. The error in HtmlCheckBox?.html: checked="${this.checked}"

"checked" must be without argument. <input type="checkbox" checked> - valid. As result, checkbox is always checked (until check-on and check-off manually).

  1. Macros ${this.checked} not changed. If look at generated HTML code in FF, we can see checked="${this.checked}" as is.

Change History (5)

comment:1 Changed 13 years ago by guest

re: point 1. See HTML40 pg 36: Boolean attributes may legally take a single value: the name of the attribute itself (e.g., selected="selected").

So <input type="checkbox" checked="checked"> is also valid. Thus one could use <input type="checkbox" ${this.checked}> and set this.checked='checked="checked"' or this.checked="".

comment:2 Changed 13 years ago by miksir@…

Yes, checked="checked" allowed, but checked="" not allowed and recognized by IE and FF as "checked" state.

comment:3 Changed 13 years ago by guest

"checked" must be without argument.

I was just taking issue with this assertion, not suggesting this is not a bug (or that it is; I've not looked at it closely).

comment:4 Changed 13 years ago by bill

Milestone: 0.4
Resolution: fixed
Status: newclosed

This was changed (and fixed) a few weeks ago; try the latest code.

comment:5 Changed 12 years ago by (none)

Milestone: 0.4

Milestone 0.4 deleted

Note: See TracTickets for help on using tickets.