Opened 7 years ago

Closed 7 years ago

#16390 closed defect (invalid)

The button on toolbar does not draw focus when move focus to it with short-cut key

Reported by: hyang Owned by: hyang
Priority: undecided Milestone: tbd
Component: Dijit Version: 1.6.1
Keywords: Cc:
Blocked By: Blocking:

Description

1: copy attache file to dijit\tests

2: visit the page

3: press tab to make focus into the first edit area

4: press CTRL+M to make the focus to toolbar

Defect: The focus is on toolbar, but have no visible focus

Notice: If you make the toolbar get focus before using short-cut key, the issue should not exist

Attachments (1)

test_Toolbar.html (8.1 KB) - added by hyang 7 years ago.

Download all attachments as: .zip

Change History (7)

Changed 7 years ago by hyang

Attachment: test_Toolbar.html added

comment:1 Changed 7 years ago by bill

Owner: changed from bill to hyang
Status: newpending

On Dojo 1.6, the Ctrl-M doesn't do anything for me, but on 1.7+, it moves the focus fine. Tested on chrome/mac since you didn't say what browser you were testing on. Is there another case that fails?

comment:2 Changed 7 years ago by hyang

Status: pendingnew

My mistake.

My ENV is Win7+ Dojo 1.6.1+ FF16

in My ENV, when press ctrl+M, the focus will move to toolbar, but the focus does not draw, and make customer does not know where the focus on. only fail this case.

Last edited 7 years ago by hyang (previous) (diff)

comment:3 Changed 7 years ago by bill

Status: newpending

Yes, but what browser? Oh, nevermind, you updated to it say FF16. I will try.

Last edited 7 years ago by bill (previous) (diff)

comment:4 Changed 7 years ago by bill

OK, well this is just the way that FF works. It doesn't show a focus outline on nodes until the user starts tabbing around. I think it's by design, because most people use the mouse and don't like the focus outline.

You can confirm the behavior by tabbing somewhere else, for example from the second input into the second toolbar, and then typing Ctrl-M. The focus outline on the cut icon in the first toolbar will now be shown correctly.

I'm sure you could override it by setting up a CSS rule but I don't want to override this default behavior. Makes sense?

comment:5 Changed 7 years ago by hyang

Status: pendingnew

I am working on ACC task, QE insist that the focus should always visible with keyboard operation.

could you give me the suggestion override which CSS rule to override the default Behavior?

Thanks in advance

comment:6 Changed 7 years ago by bill

Resolution: invalid
Status: newclosed

Here is one of many possible ways:

.dijitButtonContents:focus {
	outline: dotted black 1px;
}
Note: See TracTickets for help on using tickets.