Opened 6 years ago

Closed 6 years ago

#16383 closed defect (invalid)

DndFromDojo.js cannot access Dojo DnD Manager (API change)

Reported by: wsargent Owned by: wsargent
Priority: undecided Milestone: tbd
Component: DnD Version: 1.8.1
Keywords: Cc:
Blocked By: Blocking:

Description

See #16036, #16029 -- when calling DndFromDojo?.js, it dies with an error:

Uncaught TypeError?: Object function (){

var a = arguments, t = a, a0 = a[0], f;

if(!(this instanceof a.callee)){

not called via new, so force it return applyNew(a);

}

this._inherited = {}; perform the shaman's rituals of the original declare() 1) call two types of the preamble if(ctorSpecial){

full blown ritual if(a0){

process the preamble of the 1st argument f = a0.preamble; if(f){

t = f.apply(this, t)
t;

}

} f = this.preamble; if(f){

process the preamble of this class f.apply(this, t); one peculiarity of the preamble: it is called even if it is not needed, e.g., there is no constructor to call let's watch for the last constructor (see ticket #9795)

}

} 2) call a constructor if(ctor){

ctor.apply(this, a);

} 3) continue the original ritual: call the postscript f = this.postscript; if(f){

f.apply(this, a);

}

} has no method 'manager'

Before, the fix to #16029 was:

this._dojoManager = Manager.manager();

It now needs to be:

this._dojoManager = Manager.manager;

Change History (2)

comment:1 Changed 6 years ago by Colin Snover

Owner: changed from Eugene Lazutkin to wsargent
Status: newpending

Please provide an isolated test case on http://jsfiddle.net that reproduces this problem.

comment:2 Changed 6 years ago by trac-o-bot

Resolution: invalid
Status: pendingclosed

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

Note: See TracTickets for help on using tickets.