Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#16378 closed defect (fixed)

Tree: collapseAll() and other asynchronous methods resolve too early

Reported by: bill Owned by: bill
Priority: undecided Milestone: 1.9
Component: Dijit Version: 1.8.1
Keywords: Cc:
Blocked By: Blocking:

Description

Running this code leaves the Tree closed rather than open, like it should.

mytree.collapseAll().then(function(){
	return mytree.set("paths", [
		["continentRoot", "AF", "SD", "Khartoum"],
		["continentRoot", "SA", "AR"]				// Argentina
	]);
});

Further, it's in a weird state, as clicking the icon on "Continents" doesn't open the Tree the first time. You need to click it twice.

Test case attached.

Attachments (1)

t.html (3.7 KB) - added by bill 6 years ago.
sibling of Tree_a11y.html

Download all attachments as: .zip

Change History (5)

comment:1 Changed 6 years ago by bill

Milestone: tbd1.9
Status: newassigned

Changed 6 years ago by bill

Attachment: t.html added

sibling of Tree_a11y.html

comment:2 Changed 6 years ago by bill

Root cause is #16431, either that ticket can be fixed, or Tree can workaround.

comment:3 Changed 6 years ago by bill

Resolution: fixed
Status: assignedclosed

In [30123]:

Fix problem where collapseAll() and other asynchronous Tree methods resolve too early. Fixes #16378, refs #16431 !strict.

comment:4 Changed 6 years ago by bill

Summary: Tree: collapseAll() returns too early?Tree: collapseAll() and other asynchronous methods resolve too early
Note: See TracTickets for help on using tickets.