Opened 7 years ago

Closed 6 years ago

#16377 closed defect (invalid)

jaws14 can not read dijit dialog which is showing from a timeout ajax method

Reported by: dragonli Owned by: dragonli
Priority: undecided Milestone: tbd
Component: Accessibility Version: 1.6.1
Keywords: Cc:
Blocked By: Blocking:

Description (last modified by bill)

Steps to reproduce this issue:

  1. Create a simple ajax application using dojo toolkit
  2. In its response method, set a timeout and then show a dijit dialog. As you can see from attached Dialog.html

3, Enable jaws 14 to read the dialog

  1. Issue: Jaws just read the 'Cancel' button in the dialog. (Pressing F5 or re-request the URL)

Attachments (1)

Dialog.html (1.1 KB) - added by dragonli 7 years ago.

Download all attachments as: .zip

Change History (3)

Changed 7 years ago by dragonli

Attachment: Dialog.html added

comment:1 Changed 6 years ago by bill

Description: modified (diff)
Owner: changed from mikeb to dragonli
Status: newpending

I don't understand the test file. Is it supposed to be reading some data over XHR? It only shows the dialog when there's an error return from dojo.xhrPost(), but does that have anything to do with the issue? What if you just show the dialog?

comment:2 Changed 6 years ago by trac-o-bot

Resolution: invalid
Status: pendingclosed

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

Note: See TracTickets for help on using tickets.