Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#16375 closed defect (invalid)

Firefox 17.0 critical issues when Firebug is open

Reported by: dylan Owned by: Kris Zyp
Priority: undecided Milestone: 1.8.2
Component: Events Version: 1.8.1
Keywords: Cc:
Blocked By: Blocking:

Description

Firefox 17 appears to break Dojo and doh.

For doh, I get the following error that prevents the loading of doh (from trunk):

TypeError?: type is undefined [Break On This Error]

if(type.call){

on.js (line 83)

ReferenceError?: doh is not defined [Break On This Error]

doh.togglePaused();

onclick (line 2)

Other apps I've tested have issues with errors in on and aspect.

Change History (7)

comment:1 Changed 7 years ago by dylan

When this is called in dojo/on:

on.parse = function(target, type, listener, addListener, dontFix, matchesTarget){

every value passed in is undefined. So this may be a FF parsing issue, or an events issue.

This appears to be worse in trunk.

Testing FF 17 against 1.8.1, I see a bunch of errors in dojo/_base/connect, but no issues with dojo/on or dojo/aspect when running doh.

comment:2 Changed 7 years ago by dylan

Priority: blockerundecided
Summary: Firefox 17.0 critical issuesFirefox 17.0 critical issues when Firebug is open

Sigh, so this failure only happens for me when Firebug is open... close firebug, and things seem to run better.

comment:3 Changed 7 years ago by dylan

Resolution: invalid
Status: newclosed

Installed Firebug 1.11 beta 2, everything seems fine. Nothing to see here, move along.

comment:4 Changed 7 years ago by simpo

Just a note for anyone else who finds this issue. I had exactly the same issue using FF 17 getting "type is undefined" line 83 on dojo/on (v1.8.1 -SDK). This happened with or without Firebug open and after an upgrade to Firebug 1.11 beta. However, all was well after I removed the Dojo Firebug Extension.

comment:5 Changed 7 years ago by mfirak

Additional Note:

@simpo your tip was for me the solution: remove or disable Dojo-Firebug-Extension for dojo 1.8

my environment in detail: dojo 1.8.x + Firefox 17.0 + Firebug 1.10.6 + Dojo-Firebug-Extension 1.1.5b2

i have also TypeErrors? in different apps when using Firebug with Dojo-Firebug-Extension in dojo 1.8

my simplest usecase to reproduce a TypeError?:

localhost:8000/util/doh/runner.html?test=dojo/tests/string

results for diff. environments:

Error: dojo 1.8.x + Firefox + Firebug + Dojo-Firebug-Extension
OK:    dojo 1.8.x + Firefox + Firebug (disabled Dojo-Firebug-Extension !!)
OK:    dojo 1.8.x + Firefox
OK:    dojo 1.7.2 + Firefox + Firebug + Dojo-Firebug-Extension

The Error as printed in the console:

TypeError type is undefined
req.getText(url, legacyMode!=sync, xhrCallback);
dojo.js (line 1496)
Last edited 7 years ago by mfirak (previous) (diff)

comment:6 Changed 7 years ago by Mark DeMichele

Shouldn't this be re-opened since disabling the dojo firebug extension fixes it?

comment:7 Changed 7 years ago by Adrian Vasiliu

@demi: No, because the Dojo Firebug extension is not part of Dojo Toolkit. This ticket seems a duplicate of #15843 and #16380.

Note: See TracTickets for help on using tickets.