Opened 13 years ago

Closed 13 years ago

#1637 closed enhancement (duplicate)

Dojo chart widget enhancements

Reported by: chrism1@… Owned by: Tom Trenka
Priority: high Milestone: 0.9
Component: gfx (svg+vml) Version: 0.4
Keywords: Cc: bill@…, peller@…, ccmitchellusa@…,
Blocked By: Blocking:

Description

Suggestions for some Dojo chart widget enhancements:

  • Events -- even though it would be possible to attach event

attributes to the raw SVG/VML nodes, it would be much less tedious and error-prone if this could be done at a much higher level, perhaps at the Series or Plotter level.

  • Visibility toggling -- this is simply a matter of changing the

"visibility" style attribute on a particular group node. The one minor issue I see is that using a grouped plotter renders all the data series under the same group node. This would preclude toggling the visibility of one particular data series. I can see the argument that perhaps this is by design since the data series are supposed to be grouped together, but on the other hand it wouldn't be any real effort to group all the data series in a grouped plotter separately.

  • CSS styling -- I'm thinking this could be accomplished by saying, at

perhaps the Series or Plotter level, that all the rendered elements of a particular data series should include some given class attribute. From there CSS styling is possible, at least with SVG. For VML, since I believe it doesn't allow much styling beyond positioning and the like, we could probably have some sort of workaround that involved modifying the VML node attributes.

  • Arbitrary shapes for line plotters -- it looks like only dots are

allowed for points rendered by a line plotter. It would be useful if arbitrary shapes could be specified. In our case, we are planning on having multiple lines on the same plot cycle through a set of predefined point shapes in order to distinguish the lines.

  • Dynamic data updates -- It'd be useful to be able to dynamically add

new data points the chart. Ideally this could be done without having to re-generate all the VML/SVG from scratch since performance is a necessary consideration.

Change History (3)

comment:1 Changed 13 years ago by Tom Trenka

Milestone: 0.5
Version: 0.4

comment:2 Changed 13 years ago by Tom Trenka

Component: Widgetsgfx (svg+vml)

comment:3 Changed 13 years ago by Tom Trenka

Resolution: duplicate
Status: newclosed

Just created a number of tickets splitting these tasks out; closing this ticket in favor of the new ones.

Note: See TracTickets for help on using tickets.