Opened 7 years ago

Closed 7 years ago

#16335 closed defect (duplicate)

Usability issue with _HasDropDown and maxHeight=-1 on iPad

Reported by: Paul Christopher Owned by: Douglas Hays
Priority: undecided Milestone: tbd
Component: Dijit - Form Version: 1.8.1
Keywords: Cc:
Blocked By: Blocking:

Description

Description

See screenshot above: Typing works perfectly but you cannot choose all entries from the drop-down list: Parts of the entries are blocked by the semi-transperent top border. Scrolling the list does not work (but maybe I am not used to all the gestures on the iPad): Touching the drop down selects an entry but does not scroll the list. My impression is even this: The maxHeight of the drop down is calculated before the keyboard opens, thus the drop down is far too big. Does the calculation need a setTimeout?

Steps to reproduce the issue

Visit http://archive.dojotoolkit.org/nightly/dojotoolkit/dijit/themes/themeTester.html with an iPad, select tab "Select Widgets" and focus the FilteringSelect widget. Type in 'A' and try to choose "Armed Forces Pacific" from the list.

Discussion

Don't know whether anything can be done about this. In my eyes, a semi-transparent top bar of the keyboard is a design bug by Apple: It always blocks the interaction with the subjacent parts of the page. And since there is no event (like orientation change) for opening the keyboard, not much can be done? Opening the keyboard is just a resize event - as far as I can see.

Attachments (1)

screenshot.png (157.5 KB) - added by Paul Christopher 7 years ago.

Download all attachments as: .zip

Change History (6)

Changed 7 years ago by Paul Christopher

Attachment: screenshot.png added

comment:1 Changed 7 years ago by Douglas Hays

#16336 is a duplicate of this ticket.

comment:2 Changed 7 years ago by Paul Christopher

Ticket might be related to http://bugs.dojotoolkit.org/ticket/5777: Do not just reposition drop down but check for its size, too.

comment:3 Changed 7 years ago by Douglas Hays

Resolution: patchwelcome
Status: newclosed

We need all or part of dojox/mobile/scrollable.js in dijit/ and we need a way of detecting when the keyboard overlays part of the screen. I don't think there's an actual resize event.

comment:4 Changed 7 years ago by bill

Resolution: patchwelcome
Status: closedreopened

Actually this is fixed by #16730.

comment:5 Changed 7 years ago by bill

Resolution: duplicate
Status: reopenedclosed

Duplicate of #16730.

Note: See TracTickets for help on using tickets.