Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#16333 closed defect (invalid)

ComboBox: JAWS read nothing when press ArrowDown to show combo list

Reported by: hyang Owned by: mikeb
Priority: undecided Milestone: tbd
Component: Dijit - Form Version: 1.6.1
Keywords: Cc:
Blocked By: Blocking:

Description (last modified by bill)

1: start JAWS
2: visit http://livedocs.dojotoolkit.org/dijit/form/ComboBox[[BR]] 3: run the first sample(Programmatic example using a dojo.store)
4: move focus to combox with keyboard
5: press ArrowDown? to show the list

Defect: JAWS read nothing in step 5.

My ENV is: Win7 + JAWS14 +FF16+Dojo 1.6.1, this reproduce on newest dojo too

Attachments (1)

JAWS_ComboBox.html (1.8 KB) - added by mikeb 6 years ago.
sample html file demonstrating difference in JAWS behavior with labels

Download all attachments as: .zip

Change History (6)

comment:1 Changed 6 years ago by bill

Component: GeneralDijit - Form
Description: modified (diff)
Owner: set to Douglas Hays
Summary: JAWS read nothing when press ArrowDown to show combo listComboBox: JAWS read nothing when press ArrowDown to show combo list

comment:2 Changed 6 years ago by Douglas Hays

Owner: changed from Douglas Hays to mikeb
Status: newassigned

comment:3 Changed 6 years ago by mikeb

Resolution: invalid
Status: assignedclosed

Hello,

When you press the down arrow to open the ComboBox?, JAWS will read whatever label has been applied to said ComboBox?; if there is no label, JAWS won't read anything, which is what is going on in that test case.

I have attached a sample demonstrating how JAWS behaves differently depending on if there is a label or not.

You can set a label by either setting "aria-label":"my label", "aria-labelledby":{id}, or by using a <label> tag.

Changed 6 years ago by mikeb

Attachment: JAWS_ComboBox.html added

sample html file demonstrating difference in JAWS behavior with labels

comment:4 Changed 6 years ago by hyang

Thanks for so rapid response, I do not want to customize what should do when press Arrowdown, please listen the sample below http://archive.dojotoolkit.org/nightly/dojotoolkit/dijit/tests/form/_autoComplete.html?testWidget=dijit.form.ComboBox, it read 'bla bla, to select value, use arrow key....' when press Arrowdown, but read nothing in my sample

comment:5 Changed 6 years ago by mikeb

The reason that JAWS reads nothing in your sample is because the sample here (http://livedocs.dojotoolkit.org/dijit/form/ComboBox) does not use a <label> tag. However, the sample on http://archive.dojotoolkit.org/nightly/dojotoolkit/dijit/tests/form/_autoComplete.html?testWidget=dijit.form.ComboBox DOES use a label tag. When you press the down arrow to open the ComboBox, JAWS will speak the text in the label. Since your sample has no label text, JAWS doesn't say anything.

You can look at the HTML to see the difference. Here is the first sample HTML, JAWS WILL NOT speak anything when you press the down arrow:

    <select data-dojo-type="dijit/form/ComboBox" id="fruit" name="fruit">
    <option>Apples</option>
    <option selected>Oranges</option>
    <option>Pears</option>
</select>

In order to get JAWS to speak the instructions when you press the down arrow, change the HTML to be this:

    <label for="fruit">Select a fruit</label>
    <select data-dojo-type="dijit/form/ComboBox" id="fruit" name="fruit">
    <option>Apples</option>
    <option selected>Oranges</option>
    <option>Pears</option>
</select>

Now that there is a <label> element for the ComboBox, JAWS will read "Select a fruit, to select a value use arrow key...". JAWS only does this because we have added the label.

If you don't use the label tag, there is no way to get JAWS to speak anything when you press the down arrow. You must use a label (either <label> element, or aria-label, or aria-labelledby) if you want JAWS to speak when you down arrow.

Note: See TracTickets for help on using tickets.