Opened 6 years ago

Closed 6 years ago

#16330 closed enhancement (duplicate)

dojox/mobile/deviceTheme.js loads CSS files in reverse order

Reported by: Eric Durocher Owned by: Eric Durocher
Priority: undecided Milestone: 1.9
Component: DojoX Mobile Version: 1.8.1
Keywords: Cc:
Blocked By: Blocking:

Description

method loadCSSFile() inserts a <link> tag at the start of the <head>. When called repeatedly, this results in the <link> tags being in the reverse order of the calls to loadCSSFile(). This is not a problem for built-in themes because they do not rely on loading order of CSS files, but can be confusing for custom themes that do rely on loading order.

Change History (4)

comment:1 Changed 6 years ago by Eric Durocher

Milestone: tbd1.9

comment:2 Changed 6 years ago by Eric Durocher

Possibily a duplicate of #15371? Checking with original reporter...

comment:3 Changed 6 years ago by Eric Durocher

Status: newassigned

comment:4 Changed 6 years ago by Eric Durocher

Resolution: duplicate
Status: assignedclosed

Yes, confirmed.

Note: See TracTickets for help on using tickets.