Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#16328 closed defect (fixed)

[regression] Tree: dragging nodes selects text (FF)

Reported by: bill Owned by: bill
Priority: undecided Milestone: 1.8.2
Component: Dijit Version: 1.8.1
Keywords: Cc:
Blocked By: Blocking:

Description

On FF/win, starting with [29475] dragging a node tends to select the text of the potential drop targets (ie, the tree nodes that are dragged over). And FF/win gets failures in its DnD regression tests in the "drag between trees" test.

Change History (3)

comment:1 Changed 7 years ago by bill

Milestone: tbd1.8.2

comment:2 Changed 7 years ago by bill

Resolution: fixed
Status: newclosed

In [29939]:

Prevent text selection while dragging on desktop, fixes #16328 on trunk/ !strict. But continue to *not* call preventDefault() on mobile because it will break things completely, refs #15838.

comment:6 Changed 7 years ago by bill

In [29940]:

Prevent text selection while dragging on desktop, fixes #16328 on 1.8/ branch !strict. But continue to *not* call preventDefault() on mobile because it will break things completely, refs #15838.

Note: See TracTickets for help on using tickets.