Opened 7 years ago

Closed 3 years ago

#16326 closed defect (invalid)

Jaws reads the first input character in textarea within Accordion container twice

Reported by: dragonli Owned by: dragonli
Priority: undecided Milestone: 1.13
Component: a11y - review Version: 1.6.1
Keywords: Cc:
Blocked By: Blocking:

Description

Applying jaws 14, we found that it would read the first input character twice. This happens in textarea control which is in Accordion container. If we move the textarea out of the container , jaws reads it normally.

Steps to reproduce: 1)In dijit/tests/layout/tab1.html, we add a textarea control

<textarea id="testTextarea"></textarea>

2) Open dijit/tests/layout/test_AccordionContainer.html

3) Apply jaws 14 to read

Change History (4)

comment:1 Changed 7 years ago by mikeb

It seems like this only happens if the inputs have an aria role structure like this:

role=tablist
  role= tabpanel
    <input>

I tried to reproduce on the other layout widgets but couldn't. AFAIK this is a valid role structure (best practices guide for accordion container.) I think since it can be reproduced on a plain HTML page that it might be a JAWS14 bug. I am following up with some JAWS experts to see if this is a known issue yet or not. Thanks.

comment:2 Changed 7 years ago by dragonli

When we create a dojo grid instead of textarea within Accordion container. There is a new problem when navigating grid rows via arrow_up and arrow_down. Jaws reads the focus cell, then it will read the content of the row from which the focus is moved.

Otherwise, it is not the case.

Steps to reproduce: 1) In test_AccordionContainer.html the lazylaodPane, we just create a simple dojo grid. 2) Apply jaws 14 to read

Please also have a look at this problem. many thanks

comment:3 Changed 3 years ago by dylan

Milestone: tbd1.12
Owner: changed from mikeb to dragonli
Status: newpending

Apologies that this hasn't been touched in 3 years. Given that things have evolved quite a bit over that time, I think we'll need to know if this is still an issue, and if it needs to be fixed.

comment:4 Changed 3 years ago by trac-o-bot

Resolution: invalid
Status: pendingclosed

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

Note: See TracTickets for help on using tickets.